Title

Message

Confirm

<< DiscussionsReply

Maximizing Windows Utilizing Screen Splits

Avatar from Gravatar.com
SaberClash
3 discussion posts
Hi,

I have a 49" super ultrawide monitor that runs at a native resolution of 5120x1440. I use DisplayFusion to split the monitor in half (vertically) so I have two 2560x1440 monitors on my main display. I also have a secondary monitor that's a 27" monitor in a 1920x1080 resolution.

My question is that with the monitor I'm splitting (the ultrawide) whenever I maximize a window to the split, it only "sort of" works. It will maximize to the entire 2560x1440 area as it should, but it does not lock the window as a normal maximized window would behave. I'll give an example. If I were to take a non-maximized Google Chrome window and maximize it on my 27" monitor without any splits, the "restore" icon (the double box icon in the title bar) would appear for me to un-maximize the window - this means while the window is in that maximized state the window cannot be dragged, it is locked. On the DisplayFusion maximized windows that are on my split screen, it does not change the maximize icon and it is always the single box icon, and the window is not locked. This results in my maximized windows constantly getting dragged around the screen if I accidentally click on the title bar or what have you.

I'm wondering if there's a way to restore (no pun intended) the normal maximized behavior of a window, while still utilizing the monitor splits. I hope this wasn't too confusing, it was a little bit of a challenge to describe, but I was hoping to get some help here.

Otherwise, I absolutely love this software and it's made having an ultrawide monitor so much more enjoyable.

Thanks!
5 days ago  • #1
Avatar from Gravatar.com
Owen Muhlethaler (BFS)
202 discussion posts
Hello,

If you head to the compatibility settings in Display Fusion, add chrome, you can check off "disable maximized window dragging" and that should fix your issue. (you can also enabled this globally in the window management tab if you would like).

Let me know how that works for you!
4 days ago  • #2
Avatar from Gravatar.com
SaberClash
3 discussion posts
Owen, thank you for the reply. I think you're telling me exactly what I need to do, but I'm not able to figure out how to do it globally. In the window management section, I already have the "Enable maximized window dragging between monitors" unchecked. Is there somewhere else I should be looking?
4 days ago  • #3
Avatar from Gravatar.com
Owen Muhlethaler (BFS)
202 discussion posts
Hello,

If you have that setting unchecked in the Window Management tab, then that should do it globally. Is the issue still persisting? Does making those compatibility rules change anything?

Thanks!
1 day ago  • #4
Avatar from Gravatar.com
SaberClash
3 discussion posts
Hi Owen,

Whether I make an exception in the compatibility settings for an individual application (i.e. Firefox, Chrome, Steam, etc) OR uncheck the option in the window management tab, it still allows me to drag maximized windows.

I'm not sure what I'm doing wrong. Is there anything else you can think of?

Just to make sure I'm explaining this correctly... If I shift + maximize, the window will obviously take up both sides of my ultrawide and be fully maximized across my splits (as intended). When that happens, I cannot drag a maximized window. However, when a window is maximized to only my virtual monitor split via displayfusion, it will allow me to freely drag the window around regardless.
1 day ago  • #5
Was this helpful?    
<< DiscussionsReply