Title

Message

Confirm

<< DiscussionsReply

Multi monitor wake from sleep issue

Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Can't find this anywhere in the discussion: Running display fusion with 3 monitors, each display with it's own wallpaper during normal operation. Problem is when my computer wakes from sleep. All three monitors display the same wallpaper. Further, the two monitors displaying the wrong wallpaper are aligned incorrectly. Only way I've found to fix it is disable/unplug a monitor or restart pc. Please advise on a fix.
Nov 23, 2019  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you check for updated video card drivers and install them if they're available? Please let me know how that goes and we'll go from there.

Thanks!
Nov 25, 2019  • #2
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Yes, I'm using the latest version: 441.20
Nov 26, 2019  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, in the Desktop Wallpaper window, could you click the Wallpaper Settings button, and disable the "Use transitions when changing" option and then restart the computer to see if that makes any difference?
Nov 26, 2019  • #4
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Quote:
Ok, in the Desktop Wallpaper window, could you click the Wallpaper Settings button, and disable the "Use transitions when changing" option and then restart the computer to see if that makes any difference?


I've tried this suggestion and it does not appear to have resolved the issue. I also reviewed Event Viewer and there were not any Errors.
Nov 28, 2019 (modified Nov 28, 2019)  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, could you try this?

  • Open a Run prompt (Win + R) and enter this:
    %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\
  • In that folder, delete the "TranscodedWallpaper" file
  • Restart the computer

Does that make any difference?
Nov 28, 2019  • #6
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Quote:
Ok, could you try this?

  • Open a Run prompt (Win + R) and enter this:
    %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\
  • In that folder, delete the "TranscodedWallpaper" file
  • Restart the computer

Does that make any difference?


Hey Keith - I really appreciate your support and thank you for your time. I am testing this out now and will let you know how my experience goes.
Nov 29, 2019  • #7
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
The above suggestion did not solve this problem. Earlier today it appears to be working, but my computer just performed wake from sleep and the issue is back.
Nov 30, 2019  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
When this happens, if you exit DisplayFusion and try setting the wallpaper using the Windows settings, does it work or is it still stuck on the messed up wallpaper?
Dec 3, 2019  • #9
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Hey Keith - again I appreciate your support. At this point, this issue has only occurred one time since the last changes. Unclear to me why only once, but I'll reply on this thread if it occurs again. Otherwise I'm assuming your recommendations have corrected the issue.
Dec 5, 2019  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Sounds good, thanks for the update!
Dec 5, 2019  • #11
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
This morning when I woke my computer, the same problem occurred - only one wallpaper showing on all three monitors, two of the thre monitors' wallpaper positioned incorrectly. I right clicked on the taskbar icon and exited Displayfusion. The wallpapers reverted to their correct postion and the correct images appear.
Dec 6, 2019  • #12
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, one more thing for you to try. In the DisplayFusion Settings > Advanced Settings, could you enable the "Wallpaper: Force Desktop Refresh After Wallpaper Change" option, apply the settings, then restart the computer and let me know if the issue occurs again?
Dec 6, 2019  • #13
Avatar from Gravatar.com
Alextkexichi
8 discussion posts
Quote:
Ok, one more thing for you to try. In the DisplayFusion Settings > Advanced Settings, could you enable the "Wallpaper: Force Desktop Refresh After Wallpaper Change" option, apply the settings, then restart the computer and let me know if the issue occurs again?


Reposting here as this issue appeared to be resolved. Recently updated Displayfusion to 9.6.1 and having the same problem again. I've double checked previous settings and everything appears in order.

I deleted the TranscodedWallpaper file, but have not restarted yet.

I exited Displayfusion and the background turned solid black. Using Windows, I managed to set the 3 images correctly - FYI, "Choose a fit" is set to Tile.
Dec 30, 2019  • #14
Avatar from Gravatar.com
Roger Tubby
8 discussion posts
Cross posting from https://www.displayfusion.com/Discussions/View/triggers-and-windows-postions/

I did pick up one of those EDID emulators at Amazon for $22.99. It seems to have corrected the problem which is due to Windows not recognizing an external monitor early enough.

HDMI Pass-Through EDID Emulator for use with Video splitters, Switches and Extenders (fit-Headless) 3840x2160@60h&Attention:(NOT Support Dp to HDMI Adapter Cable Connection )
by FUERAN
Jan 1, 2020  • #15
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply