Title

Message

Confirm

<< DiscussionsReply

Screen saver doesn't launch when docking station in use.

Avatar from Gravatar.com
Patrick M. Kelly
5 discussion posts
Greetings. I've been trying to figure this out for a week now and can't figure it out. I have DF installed on my Windows 10 laptop. When my laptop is both (A) attached to my docking station with external monitor; and (B) running DisplayFusion, the screen saver will not come on. If either of these conditions changes -- unplug from docking station OR kill the DisplayFusion process -- then everything works fine and the screen saver comes on as advertised.

It seems that DisplayFusion is interfering with the Windows trigger mechanism for the screen saver, but only when connected to a docking station. This happens regardless of whether DF is controlling the screen saver or not. That is, the check box for "Allow DisplayFusion to manage the Screen Saver" can be checked or not. Either way, same behavior.

Version is 9.6.1.

Thoughts?
Jan 23, 2020  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I haven't run into that before! When DisplayFusion is running, if you run the following at an elevated command prompt, does anything show up there as preventing the computer from going idle?

powercfg /requests
Jan 27, 2020  • #2
Avatar from Gravatar.com
Patrick M. Kelly
5 discussion posts
Hi, Keith. Thanks for the response. I ran the command you suggested from an elevated command prompt, and it did not show anything of interest. Everything came back
None
.

C:\WINDOWS\system32>powercfg /requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.
Jan 27, 2020 (modified Jan 27, 2020)  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, do you have the screen saver configured through DisplayFusion, or just through the normal Windows settings?
Jan 28, 2020  • #4
Avatar from Gravatar.com
Patrick M. Kelly
5 discussion posts
I have tried both. My "default/desired" is to just use the Windows screen saver. When that didn't work, I tried to change to the DF screen saver. I see the same behavior in each case.
Jan 28, 2020  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, could you do one more test just to re-confirm whether DisplayFusion is interfering here?

  • Disable the screen saver in DisplayFusion
  • Enable the screen saver in Windows
  • Set the timeout to 1 minute
  • Exit DisplayFusion, does the screen saver start?
  • If so, start DisplayFusion, does the screen saver start?

Thanks!
Jan 28, 2020  • #6
Avatar from Gravatar.com
Patrick M. Kelly
5 discussion posts
Done (with the exception that I do not have control over timing, as it is fixed by our administrator at 15 minutes). Without DF, the screen saver starts fine. When DF is running, the screen saver does not start.
Jan 28, 2020  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
If you disable some of the features (taskars, titlebar buttons, etc), do any of them make any difference?
Jan 31, 2020  • #8
Avatar from Gravatar.com
Patrick M. Kelly
5 discussion posts
Solved! Couldn't tell you the precise details of what was causing the issue. I disabled everything I could find, with the exception of Windows Position Profiles. I was prompted to restart my system for the changes to take effect, and at first glance, it appears to be working now. Thanks for your assistance.

If I get some time to experiment with the settings, and if I can narrow down the culprit, I will let you know what I find. Thanks!
Feb 3, 2020 (modified Feb 3, 2020)  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Sounds good, thanks Patrick!
Feb 3, 2020  • #10
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply