Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

System is lagging since upgrade to Windows 10

Avatar from Gravatar.com
Christian Treffler
28 discussion posts
Hi,

I have upgraded my Laptop from Windows 7 to Windows 10. Since then I find the system very slow in response. That' not specific to special actions, but more an overall behavior. The system takes half a second for "contemplation" before reacting to mouse clicks. Audio notifications are not in sync with the notification messages.
When I exit DisplayFusion, the problem vanishes and the system is up to normal speed. Restarting DisplayFusion causes the system to drag it's feet again. Sometimes even mouse movements are not smooth anymore.
I have a small template program, which is started with a hotkey. Without DisplayFusion running the program starts immediately. With DisplayFusion running there's a 1s delay. CPU usage of DisplayFusion is in the 0% to 3% range.

So right now DisplayFusion is seriously hampering my workflow. Not running it also affects my accustomed workflow

I attached a debug info from DisplayFusion. Maybe it helps to find out what's going on?

Regards,
Christian
• Attachment [protected]: DisplayFusionDebugInfo.zip [21,617 bytes]
Mar 23, 2018  • #1
Avatar from Gravatar.com
Peter DeSimone
10 discussion posts
I can concur with that. According to Task Manager, DisplayFusion (9.1) can suddenly be taking all the CPU. I have to stop the process and manually restart and then it is back to normal.

Unfortunately, this happened on a work laptop running Windows 7, and I got a new laptop with Windows 10 and haven't installed DisplayFusion yet.

I don't notice this on my home computers, but I do use my work computer alot more.

FYI

Peter

Sorry, I just found this thread, there are responses from Binary Fortress:
https://www.displayfusion.com/Discussions/View/high-cpu-usage/?ID=f33d2867-3020-454c-bea1-1604f6cc91c0
Mar 25, 2018 (modified Mar 25, 2018)  • #2
Avatar from Gravatar.com
Christian Treffler
28 discussion posts
Hi,

I don't think that I have the same issue as Peter. In my case DisplayFusion does not use up all the CPU.
I also tried reverting back to version 8.1.2, but the symptom persists: When DisplayFusion is running, every action needs half a second processing before it's executed.

Edit:
I tried disabling triggers (had one for Monitor Configuration change), but that did not change behaviors.
I also tried "Run as Administrator" (Although my account is already an Administrator account), but that didn't help either.

Christian
Mar 26, 2018 (modified Mar 26, 2018)  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Christian: If you enable the "Disable Application Hooks" option in the Settings > Advanced Settings window, then restart DisplayFusion, does that make any difference?
Mar 28, 2018  • #4
Avatar from Gravatar.com
Christian Treffler
28 discussion posts
Hi Keith,

that's it! I can work now again with DF running.
Not sure which functions I'm going to miss, but the most important functionality is there.

If I can help in any way figuring out why Application Hooks slow the system, let me know.

Thanks,
Christian
Mar 29, 2018  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, that's interesting! Could you re-enable the hooks and send me a debug log?
  1. On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L2: Log Detailed" and click Apply
  2. Reproduce the issue and note the time so we'll know where to check in the log file
  3. Click the "Export Info to File" button on the Settings > Troubleshooting tab
  4. Reply with the file attached
  5. Disable debug logging after sending the log
Mar 29, 2018  • #6
Avatar from Gravatar.com
Christian Treffler
28 discussion posts
Hi Keith,

here's the file, as per your instructions. I enabled logging on 30-Mar-2018, at 7:50pm. Then I played around in the system a bit (opening folders, looking at documents, working in Outlook). Everything is lagging a bit, mouse movements sometimes are jumping.

Software "TeDaPro" is running in the background (notification area) and the hotkey Ctrl-Q is assigned to launch it's window.
After starting DF, The TeDaPro window comes up immediately the first one or two trials, then there is at least a 1s delay.
Without DF running or with Application Hooks disabled, TeDaPro always shows up immediately.

Regards,
Christian
• Attachment [protected]: DisplayFusionDebugInfo.zip [443,674 bytes]
Mar 30, 2018  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! The only two processes that seem to be hooked are explorer.exe and TeDaPro.exe. Can you try creating a Compatibility rule for *TeDaPro.exe, and in the rule, enable the "Disable Application Hooks" option? You'll need to apply the settings and restart DisplayFusion for the changes to take effect.
Apr 4, 2018  • #8
Avatar from Gravatar.com
Christian Treffler
28 discussion posts
Hi,

I tried it, but it did not change the behavior.

Correction:
Disabling Application Hooks for '*TeDaPro.exe' does not work.
But doing that for 'C:\Program Files (x86)\pics\TeDaPro\TeDaPro.exe' helps.

Christian
Apr 4, 2018 (modified Apr 4, 2018)  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, interesting! So there's no more lag now that TeDaPro isn't being hooked?
Apr 5, 2018  • #10
Avatar from Gravatar.com
Christian Treffler
28 discussion posts
I have been on vacation and didn't use my laptop extensively last week. The TeDaPro issue was really bad, because I rely heavily on that program. But it seems to me that any other lag is not due to DF, but rather due to Windows 10 itself.
Work is back to smooth operation now.

Thanks for your help.

Christian
Apr 9, 2018  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, glad I could help!
Apr 9, 2018  • #12
Avatar from Gravatar.com
psbrightly
2 discussion posts
I'm experiencing something very similar. I don't use a huge number of features in DF. And I think this could be related to Windows a builds. I was on insider-track for dev builds, but then got off of it.
Basically, it can take 4 seconds to switch to some windows when I click on them. I don't know if I can disable application-hooks, as my most coveted feature stops -- mouse travels properly (straight) to my 2nd (bigger) monitor.
Turning off app hooks does make window switching instant. Got a suggestion for me? I turned on logging as suggested, but it may contain sections with it turned on & off.
• Attachment [protected]: DisplayFusion.log [2,133,965 bytes]
5 days ago  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@psbrightly: Could you send me a copy of your troubleshooting info? Here are the steps:

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached
5 days ago  • #14
Avatar from Gravatar.com
psbrightly
2 discussion posts
Keith Lammers (BFS), as requested...
Do you need anything else?
• Attachment [protected]: DisplayFusionDebugInfo.zip [399,103 bytes]
5 days ago (modified 15 hours ago)  • #15
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! If you disable the "Aero Colour Mode" option on the DisplayFusion Settings > Options tab, that will fix this up. It has issues with Windows 10 that we can't resolve from our end, so we'll be removing it in the next beta.
12 hours ago  • #16
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply