Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Allow a program to ignore monitor splits?

User Image
Patchfoot
3 discussion posts
I have a couple programs I want to always ignore my desktop splits, is there a way to white list them or something?

I've been having another issue where whenever my computer wakes from sleep it throws all my windows everywhere. I solved that with DF triggers to save/load window positions. Unfortunately, it doesn't remember if I've held shift and fully maximized a window.

This is further complicated because one of the programs I commonly use (Unity) has its layout changed if the window size changes. So if I forget to close Unity I have to always hold shift maximize and then fix its layout. I'm hoping to avoid that.
Feb 17, 2019  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
There isn't currently a blacklist for monitor splits, but it's on our feature request list, so I've added your vote to it.

I was able to reproduce the issue with the window that was maximized to the full monitor only getting maximized to the split after restoring the positions, and I've added that to our list to fix up as well.

Thanks!
Feb 19, 2019  • #2
User Image
Acru
6 discussion posts
Quote:
There isn't currently a blacklist for monitor splits, but it's on our feature request list, so I've added your vote to it.


Can you add this to the app compadibility settings now? You took away a workaround I was using, in version 9.5;

Quote:
Fix: Using Shift as a modifier on the key combination for the "Maximize Window" Function no longer overrides splits


If I could just override for certian document apps, where I always want to use the whole screen, it would be ideal.
Jun 16, 2019  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Acru: You can still do Shift + Maximize on the caption button on the titlebar. That change only changed the behaviour if you set a key combination like Shift + Ctrl + F1 on the "Maximize Window" function on the Settings > Functions tab. Is that what you were using before?
Jun 18, 2019  • #4
User Image
Acru
6 discussion posts
Quote:
@Acru: You can still do Shift + Maximize on the caption button on the titlebar. That change only changed the behaviour if you set a key combination like Shift + Ctrl + F1 on the "Maximize Window" function on the Settings > Functions tab. Is that what you were using before?


Yeah, I was using keys only before.

Using shift+click does still maximize ignoring splits, but I notice that un-maximizing afterwards causes the window to jump to the next monitor, (from split monitor 4 to monitor 5), and DF considers it still maximized.

Plus I'd like to be able to use maximized dragging to the full screen, for some apps, rather than un-maximizing and then shift-click maximizing.

Of course I could just un-split the monitor, but splitting is convenient for video windows, to have the portrait monitor split into two of better aspect, where document windows work better with the full screen.
Jun 18, 2019 (modified Jun 18, 2019)  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
For the key combinations, you can set a key combination on the "Maximize Window (ignore monitor splits)" function and that should hopefully give you the same functionality as before.

You can also hold Shift while dragging the window to the top of the screen to maximize override.

We do still have the request on our list for a Compatibility rule that would have certain applications ignore splits, so we'll be sure to let you know when that's been added as well.

Thanks!
Jun 19, 2019  • #6
User Image
Acru
6 discussion posts
Quote:
You can also hold Shift while dragging the window to the top of the screen to maximize override.


This does not appear to work?

Holding shift before dragging a maximized window causes nothing to happen, holding shift after starting the drag but before dropping seems to abort the move. (Win 7-64)
Jun 19, 2019  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Maybe I'm testing differently than you? Check out the attached video. First I maximize to each split normally, then I hold Shift and drag the window to the very top of the screen. Is that the same as what you're doing?
• Attachment: maxoverride.mp4 [1,353,535 bytes]
Jun 20, 2019  • #8
User Image
Acru
6 discussion posts
Quote:
Maybe I'm testing differently than you? Check out the attached video.


Ok I see now, you are using the Aero Snap feature of Windows in that video. I have that disabled in Windows as it can interfere with the window snapping feature in DF.

Areo Snap can also cause windows to snap across multiple screens, when resizing by dragging the edge of a window to the edge of the screen, which I don't want.
Jun 20, 2019  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ah ok. We're going to have a look for one of the next few betas to see if we can add the Compatibility option then. I'll keep you posted as soon as we've been able to implement it.

Thanks!
Jun 21, 2019  • #10
User Image
Acru
6 discussion posts
Alright, thanks~
Jun 21, 2019  • #11
User Image
smakdafrog
4 discussion posts
Quote:
I have a couple programs I want to always ignore my desktop splits, is there a way to white list them or something?


I'd like to add my reqest for this feature as well. Would make playing games easier when using borderless fullscreen; currently I have to either go fullscreen, Windowed (+shit maximize), or turn display fusion off if I actually want borderless Windowed. Is there a specific thread or forum I need to post this in instead?
Jul 5, 2019  • #12
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Here is fine, I'll add your vote to the feature request.

Thanks!
Jul 8, 2019  • #13
User Image
Lum
42 discussion posts
Was this ever implemented? If so how do you enable it?

Asking because I have a 3 way split on my 32:10 monitor, and it creates weird issues with Serious Sam 4 in fullscreen mode, HUD Stretch, and menu problems where the in-game menus are shown on the left-most split, but you have to click where they would appear if they were in the middle split. Clicking on the left, switches to whatever application is running on the desktop in that space.
Oct 24, 2020  • #14
User Image
smakdafrog
4 discussion posts
as far as i know it wasn't.
Oct 24, 2020  • #15
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

This hasn't been implemented, but we do still have it open as a feature request.

One thing you can try is opening the Compatibility tab in Display Fusion, adding the application you would like, and checking off "Disable Application Hooks (This Application)".

Thanks!
Oct 28, 2020 (modified Oct 28, 2020)  • #16
User Image
Graham Connolly
1 discussion post
Any news? Age of Empires 2 Def Ed needs to be able to ignore my split screen.

Using the options in "compatibility" does not help.
Jun 26, 2022 (modified Jun 26, 2022)  • #17
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Nothing further, sorry!
Jun 27, 2022  • #18
Was this helpful?  Login to Vote(1)  Login to Vote(-)