Title

Message

Confirm

Chrome apps not pinning correctly

lowfat
1 discussion post
DisplayFusion 9.2 (and beta 2)
OS Windows 10 Pro 1809

Just updated to Windows 10 from 8.1. In Windows 8.1, the Chrome Apps I was using pinned perfectly. Google Play Music and Keep kept their their own seperate icons and opened properly w/o having to modify the shortcuts. If I pin them now, they open a regular chrome page unless I modify the shortcut. And even then they still use a generic Chrome icon. Any ideas of a fix?

Thanks.
Aug 23, 2019  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It seems like every time we fix this issue, either Chrome or Windows updates break it again

I've added this to our list to look into again and we'll be sure to let you know when we're able to get it fixed up.

In the meantime, I've attached a screenshot of how I was able to get a Chrome pinned app working for launching. You'll need to set a custom icon in the shortcut settings, and it won't combine with the running one though.

Thanks!
Aug 23, 2019  • #2
Danny64156
4 discussion posts
Is there any update on a fix for the pinned Chrome app icons issue?
Jan 10, 2020  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Not yet, sorry
Jan 13, 2020  • #4
Danny64156
4 discussion posts
This is still a relatively big annoyance for me. Is there any prospect of getting this fixed (again)? Is there anything I can do to help the developers with this (such as gathering log files or running troubleshooting commands)? Thanks!
Mar 11, 2020  • #5
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Thank you for reminding us about this issue, we'll take another look at it for the next release. I can't promise anything though, it depends what has changed in Chrome or Windows. Thanks!
Mar 19, 2020  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've just released a new [URL=https://www.displayfusion.com/Download/Beta/]DisplayFusion Beta[/URL] version and this issue should be all fixed up. You may need to un-pin/re-pin your Chrome apps to the DisplayFusion taskbar after updating. Please let us know if you run into any trouble after updating.

Thanks!
Apr 8, 2020  • #7
shoitz
4 discussion posts
I just tested this out (9.7 beta 16) and it's working for me! Guess we'll see how long it takes for Chrome/MS to break something
Jun 9, 2020  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Glad to hear it!
Jun 9, 2020  • #9
Dana D99665
1 discussion post
Thank you for addressing this issue. I upgraded to Win 10 recently and this has been bugging me. Chrome apps appear as they should with this Beta version.
Jun 21, 2020  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Excellent, glad to hear it!
Jun 22, 2020  • #11
Andrew7
2 discussion posts
Appears to be broken again in 10.0 (Beta 3). Pinned Chrome App works fine on monitor with Windows 10 task bar. When I move the window to where I want to pin it, the icon changes from the icon of the app to the Google Chrome icon. Closing and reopening the pinned app just opens Chrome
Jul 16, 2021  • #12
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Andrew,

Thanks for letting us know, we'll open the issue back up.
Jul 20, 2021  • #13
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

This issue should be fixed up in the latest beta, available here: https://www.displayfusion.com/Download/Beta. Please let me know if you still run into any trouble after updating.

Thanks!
Nov 5, 2021  • #14
Kevlingo
3 discussion posts
Hello,

I'm using Pro 9.9 and am running into this issue. I have a Gmail as an app. When I pin it to the taskbar, a copy of the icon appears. When I close Gmail and click on the pinned item, another icon shows for Gmail (giving me 2 again).

I tried installing the beta version and it's still doing this. Any ideas?

Thanks!
Kevin
Apr 6, 2022  • #15
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Kevin,

So it's opening to the correct location, but it's not combining with the pinned icon on the taskbar?

Thanks!
Apr 7, 2022  • #16
Kevlingo
3 discussion posts
Quote:

So it's opening to the correct location, but it's not combining with the pinned icon on the taskbar?

Thanks for the reply!

Correct. I noticed in the settings for the pinned item that it was pointing to chrome_proxy.exe. I changed that to just use chrome.exe and that worked for opening Gmail. However, I also have Google Messages for Web (which does the same thing) but when I change that to use chrome.exe, it just turns into a regular Chrome icon and opens a blank site.

FYI, I was using the beta version of 10 and the above changes didn't work at all in it. Once I went back to 9.9, I was able to at least get the Gmail icon to perform as expected.

Kevin
Apr 7, 2022 (modified Apr 7, 2022)  • #17
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Kevin,

What version of Chrome are you currently running? I can reproduce the icons not combining on my end, but launching Gmail and Google Messages both seem to work fine without adjusting the application path.

Thanks!
Apr 8, 2022  • #18
Kevlingo
3 discussion posts
Sorry. I don't think I was communicating the problem correctly. What you are describing is the problem I'm having. The icons do launch correctly. They just don't combine with the launch icon.

Thanks,
Kevin
Apr 9, 2022  • #19
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Ah thanks for clarifying, I've opened this back up for us to take a look into.

Thanks!
Apr 11, 2022  • #20
Was this helpful?  (-)  (1)