Save up to 50% off any of our desktop apps in our 2021 spring sale, including
DisplayFusion, ClipboardFusion, FileSeek, LogFusion, TrayStatus, and VoiceBot!




<< DiscussionsReply

Classic shell start menu opening in the background

8 discussion posts
I just switched from Win7 to Win10 (new install, not upgraded).

When using Classic shell with DF-taskbars the start menu will open behind other windows.
This is not consistent however. The must reliable way to reproduce this is to have a borderless window in focus on the primary monitor and a maximized window on the the secondary monitor
This is not the case, when using either software alone (DF with default menu/classic shell with default taskbar).

I used clean installs of both (naturally on a fresh system).
The secondary monitor has a different aspect ratio than the primary.

A second issue (not sure if related) is that when clicking the start menu multiple times it will open on the primary monitor instead of the secondary. Waiting a short period of time (half a second to a second) will allow the menu to open on the correct sceen again.
This issue is highly reproducable.

I attached a log ("Log All") of me trying to open the startmenu twice. The fist time it opened on the primary, the second time in the background (of a firefox window. The issue is not unique to firefox windows tough)

I also attached both my classic shell and DF settings.

EDIT Aug 2020: For anymone looking at this thread in the future for a solution: There is none up to now, I swapped to Start10 instead of Classic shell, wich works fine with display fusion ¯\_(ツ)_/¯
• Attachment [protected]: DisplayFusion Backup (2018-01-24 @ 13-51,, DESKTOP-DD4NILV).reg [107,136 bytes]
• Attachment [protected]: Menu Settings.xml [2,142 bytes]
• Attachment [protected]: Opening in Background.log [915,719 bytes]
Jan 24, 2018 (modified Aug 9, 2020)  • #1
Keith Lammers (BFS)'s profile on
Is the window on the Primary monitor full screen borderless, or just any sized borderless window?
Jan 26, 2018  • #2
Keith Lammers (BFS)'s profile on
Please disregard my last question. I was able to reproduce this and have added it to our list to fix up.

Jan 26, 2018  • #3
Name Searcher
1 discussion post
I was able to reproduce this and have added it to our list to fix up.

im sorry for posting this here but has this ever been fixed or is it a setting i missed because im having the same issues and this is the only thing i can find on it.. (been ooking around for a fix for weeks now) its not the end of the world just annoying to deal with since it happens on both my etended desktop monitors (not on my main) i added my settings in attachements. let me know if any other logs are necessary and i hope to get a response soon (if any)
• Attachment: Menu Settings.xml [3,432 bytes]
Jun 14, 2020  • #4
Keith Lammers (BFS)'s profile on
This issue is still open on our list, we haven't been able to find a solution for it yet, sorry!
Jun 14, 2020  • #5
57 discussion posts

I have the exact same problem (Classic Start Menu opening in background).
Here are my findings, I hope this is helpful.
Conditions needed for the bug to happen:
1) any full screen application open (games, video, etc)
2) doesn't matter if borderless or "real full screen" or whatever they're called
3) on primary desktop only - doesn't happen if those full screen windows are located on any extended desktops (I have 4 in total, only affects primary, also not dependent on which one is set to primary)
4) the window is maximized - doesn't happen if it is restored to normal window, even if it triggered the problem when it was maximized, just restoring to regular window makes the start menu work again
5) only affects Classic Start Menu, not the original (no matter which key/click combo I set to invoke Classic or Win style Start menu)

What I have found out in regards to root cause and towards to a possible fix so far:
1) If a trigger app is already open, I can temporarily fix this by setting "Ignore Full Screen Windows" to disabled, then restarting DF, then set it back to enabled. Unfortunately, leaving it disabled is not an option because I don't want the taskbar to always appear in front of full screen windows.
2) Restarting DF after setting it back to enabled brings back the problem, even if I didn't close the trigger app.
3) Opening a trigger app when the option is set to enabled causes the bug to happen.
So this "fix" only works until I don't restart DF or the PC or any of the trigger apps.
I've tried to enable/disable just about every single option related to either full screen, taskbar or start menu or hooks or clicks, this is the only one that makes any difference.

Note: I have tried with both Classic Shell and Open Shell. Behavior is exactly the same.
Aug 5, 2020  • #6
Keith Lammers (BFS)'s profile on
@Hollo: Thanks for the additional notes on this! If you have a full screen browser on the Primary monitor (press F11 to get full screen), can you reproduce this issue as well? Or does it need to be a full screen game specifically?
Aug 7, 2020  • #7
57 discussion posts
Hey, thanks for picking this up! It's reproducible with anything fullscreen, tested with games, vlc and now browser too.
Aug 8, 2020  • #8
Keith Lammers (BFS)'s profile on
Could you send me a copy of your troubleshooting info? Here are the steps:

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached
Aug 10, 2020  • #9
57 discussion posts
here it is. hope it helps.
• Attachment [protected]: [28,919 bytes]
Aug 10, 2020  • #10
Keith Lammers (BFS)'s profile on
Thanks! I'll do some more testing with this and see what I can find out.
Aug 13, 2020  • #11
57 discussion posts
Sweet, thank you!
Meanwhile I just discovered another detail: if the fullscreen app is in the background (behind some regular window, doesn't matter if it's maximized or not), the issue is not triggered.
Aug 13, 2020  • #12
Keith Lammers (BFS)'s profile on
I think I was finally able to reproduce this issue here now! Does it only happen if the full screen window on the Primary monitor has focus? I can only get it to happen in that scenario. If I click on the maximized window on the second monitor, then everything works fine.
Aug 19, 2020  • #13
57 discussion posts
I'm not sure what focus means in this context. What I meant in my previous comment is:
There are 2 windows on primary monitor, 1 fullscreen, 1 non-fullscreen (anything else, can be maximized or smaller).
Fullscreen window is on top - issue is triggered.
Fullscreen window is still there but the other window is on top of it - issue is not triggered.
What window is active does not matter - can be either something on the primary or anything on any secondary monitor. The only thing that changes the behavior is which one is on top on the primary monitor.
Aug 19, 2020  • #14
Keith Lammers (BFS)'s profile on
Ok, right. That's definitely what I'm seeing here as well. Thanks for confirming! If we're able to get this fixed up in a future update, we'll be sure to post an update here!
Aug 20, 2020  • #15
57 discussion posts
Awesome, thank you! When you have a nightly/beta build with the fix, I'd be happy to help testing!
Aug 20, 2020  • #16
57 discussion posts
Any progress on this please?
Dec 15, 2020  • #17
Keith Lammers (BFS)'s profile on
Possibly! We resolved a similar issue with Classic Shell in one of the recent betas. Not sure if it will fix up your specific issue, but if you could give it a try, that would be great!

  • On the Settings > Options tab, enable the "Check for new Beta (newer, unstable) versions" option
  • Click the Apply button
  • Click the "Check for Updates" button
Dec 15, 2020  • #18
57 discussion posts
Wow. I'm actually using Beta9 just didn't think to try this because there was no mention of anything similar in the changelog. It indeed seems to be working now!
Dec 15, 2020  • #19
Keith Lammers (BFS)'s profile on
Excellent, glad to hear it! Thanks for following up!
Dec 17, 2020  • #20
Was this helpful?    (1)
<< DiscussionsReply