Processing Ajax...

Close Dialog


Close Dialog

Close Dialog

Detect window based on command line parameters containing a certain string

User Image
2 discussion posts

I'm a long time user and lover of DisplayFusion. Thanks for your hard work on this!

I have a program that I'd like to detect that contains the command-line arguments...

--embedded-browser-webview=1 --webview-exe-name=ChatGPT.exe

Those are not all of the arguments, but are the ones I want to detect. When I type those into the field, DisplayFusion does not detect them. I'm assuming that it matches the entire command-line parameters of the program instead of just the ones I typed?

How can I have it match some of the parameters rather than all of them?
I did try escaping the
prefix in case that was the issue. I also tried putting the parameters in quotes. I also tried using the
operator, but I'm still missing something.
For example, the entire command-line parameters for the program are...

--embedded-browser-webview=1 --webview-exe-name=ChatGPT.exe --webview-exe-version=0.12.0 --user-data-dir="C:\Users\User\AppData\Local\com.lencx.chatgpt\EBWebView" --noerrdialogs --embedded-browser-webview-dpi-awareness=2 --disable-features=MojoIpcz,msWebOOUI,msPdfOOUI,msSmartScreenProtection --lang=en-US

But I just want to match

--embedded-browser-webview=1 --webview-exe-name=ChatGPT.exe

on the trigger.

Also, is there any way to match an EXE based on filename rather than the full path? For example, can I use
instead of the full path? Right now it doesn't seem to detect with just the filename. The reason for this is that some EXEs may exist in multiple locations depending on version number or for various other reasons.


C:\Program Files\Common Files\Adobe\Microsoft\EdgeWebView\msedgewebview2.exe
C:\Program Files (x86)\Microsoft\EdgeWebView\Application\113.0.1774.42\msedgewebview2.exe

But I want to match just

Finally, I noticed a small bug with the DisplayFusion discussions forum. If I have new lines in my post, it does save them, but when I go back to edit my post, it removes the new lines and I have to add them back for easier readability. 😊 In addition, when I go back to edit my post, "Protect these attachments" is checked, even though I unchecked it before. If I save it as unchecked, when returning to editing, it still is checked.

Thank you!
• Attachment: DisplayFusionSettings_9zG7vi2mtm.jpg [70,112 bytes]
15 days ago (modified 15 days ago)  • #1
Owen Muhlethaler (BFS)'s profile on
You can use *msedgewebview2.exe to match just the process name, but the command line parameters don't support wildcards.

We'll get those discussion issues fixed up as well.

9 days ago  • #2
User Image
2 discussion posts
Okay, thank you.
9 days ago  • #3
Was this helpful?  Login to Vote(-)  Login to Vote(-)