Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Display Fusion & World of Warcraft problem

Avatar from Gravatar.com
urza
11 discussion posts
So when I'm running WoW in maximized windowed mode I'm having some problems generated by Display Fusion 3.0.6. Wasn't an issue with previous versions.

When WoW goes to a load screen, the screen goes black and the windows cursor appears (with the busy cursor displayed.) After a bit the load screen reappears with the load bar full and then play resumes as normal.

Why is this an issue? Well sometimes when the screen goes to black WoW crashes. Not good. It has also doubled, sometimes tripled the amount of time I spend on the load screen. Which is not good either.

Solution 1, no windows mode.. which means I can't take advantage of dual monitors, I have to alt-tab out of WoW, which minimizes WoW and defeats the whole point of this set up.

Solution 2, right click Display Fusion's taskbar icon and disable the Multi-monitor Taskbar. This in itself isn't bad, I can still run in windowed mode and run my mouse off WoW to the second monitor, but is just a hassle and makes multitaking on the other monitor a bit of a pain. It also defeats the purpose of having Display Fusion. :P

Anyone know if there's a setting in DF that'll fix this? Using Vista.
Jul 2, 2009  • #1
Avatar from Gravatar.com
benway
342 discussion posts
Jon's working on "disabling system hooks" when full screen games are detected, but that won't do anything for windowed WoW (how I run it also). I think it may be time to add this in as a right-click menu option to quickly disable the hooks when you need to...
Jul 2, 2009  • #2
Avatar from Gravatar.com
urza
11 discussion posts
So how will that fix my problem? Does that mean I can run without windowed mode and mouse out of WoW to monitor 2 or does it mean my screen won't go black anymore an DF won't interfere with WoW?
Jul 2, 2009  • #3
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
@Urza: Can you give the "Prevent System Hooks" setting a try for me? You can find it on this page:
http://www.binaryfortress.com/displayfusion/settings-adv/

You will need to create the "PreventSystemHooks" registry key, and set the value to "1". After setting this, you can confirm that DisplayFusion is obeying it by looking in the "Troubleshooting" tab in the Settings window. Look for the line that says "System Hooks Disabled: True". Thanks, I'm looking forward to hearing if this takes care of the issue.
Jul 3, 2009  • #4
Avatar from Gravatar.com
urza
11 discussion posts
What value am I setting to 1?
Jul 4, 2009  • #5
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Create a key called "PreventSystemHooks" and set it to a value of 1.
Jul 5, 2009  • #6
Avatar from Gravatar.com
urza
11 discussion posts
Do you mean set the "default" of the key to 1? Because when I create a "key" it creates a folder with a default of 0.
Jul 18, 2009  • #7
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Sorry, I meant create a string value, not a whole new sub-key.
Jul 19, 2009  • #8
Avatar from Gravatar.com
urza
11 discussion posts
I tired that and it still doesn't work.
Aug 12, 2009  • #9
Avatar from Gravatar.com
Kyanar
7 discussion posts
Er, this isn't DisplayFusion's fault - the game does that on stock Windows Vista and Windows 7 without any extra programs running.
Sep 3, 2009  • #10
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
In an effort to cleanup the DisplayFusion forum, this topic is being locked and archived because it applies to an older version of DisplayFusion. If you are using the latest version of DisplayFusion and would still like some assistance, please create a new topic and I'll be happy to help you out. Thanks!
Jan 12, 2010  • #11
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply