Title

Message

Confirm

DisplayFusion causing stutters in games

Bruce Wayne93487
5 discussion posts
I've been playing Watch Dogs:Legion for the past week and a half and it was running fine, but recently (past few days?) my game was stuttering every second. It took me a while to troubleshoot, but the culprit was DisplayFusion - leaving it running while playing my game was causing the stutters, but when i closed the program, the game ran smoothly again. Was there a recent update pushed? Logs attached. Link to video of stuttering [URL=https://drive.google.com/file/d/100qS2p5veEOOZul33ZpCi2L8jteKcRnE/view?usp=sharing]here.[/URL]
• Attachment [protected]: DisplayFusionDebugInfo.zip [30,636 bytes]
Oct 31, 2021 (modified Oct 31, 2021)  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Bruce,

Strange, we haven't pushed any updates to our stable build in that time span. Could you try adding the game to the Compatibility tab in the DisplayFusion Settings window, and turn on "Disable Application Hooks", and see if the issue persists after a reboot?

Thanks!
Nov 2, 2021  • #2
Bruce Wayne93487
5 discussion posts
The issue still persists after following your instructions. Ive tried other games from my steam library and they seem to be running fine with DisplayFusion. Its just this title for some reason. Its launched from the Epic Games launcher as well as the Ubisoft Uplay launcher.
Nov 2, 2021  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Bruce,

Can you try disabling all 3 system hooks in the DisplayFusion Advanced Settings (Applications, Polling, and Shell), and see if that helps after a restart?

Thanks!
Nov 3, 2021  • #4
Bruce Wayne93487
5 discussion posts
Unfortunately, the game is still stuttering with those advanced settings off and the game under the compatibility tab. I am not sure if this will be of any help, but here is another log file while the game is running.
• Attachment [protected]: DisplayFusionDebugInfo.zip [70,350 bytes]
Nov 4, 2021  • #5
Renato Zanetti64838
2 discussion posts
Yeah, can confirm this happened to me too. Watch Dogs Legion, Ghost Recon Breakpoint and Wildlands.
Nov 4, 2021  • #6
Renato Zanetti64838
2 discussion posts
I was on Windows 11 and thought this was a Windows/AMD issue. Rolled back to Windows 10 and still happened.
Nov 4, 2021  • #7
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

This might be an issue with DisplayFusion trying to inject titlebar buttons into the window. If you open the DisplayFusion Settings > Functions, can you uncheck "Enable Titlebar Buttons" and see if that helps?

Thanks!
Nov 8, 2021  • #8
Bruce Wayne93487
5 discussion posts
Quote:
Hello,

This might be an issue with DisplayFusion trying to inject titlebar buttons into the window. If you open the DisplayFusion Settings > Functions, can you uncheck "Enable Titlebar Buttons" and see if that helps?

Thanks!


That appears to have fixed the issue. Thanks!
Nov 8, 2021  • #9
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Bruce,

Glad to hear! If you want to disable titlebar buttons for just that application and keep them on the rest of your windows, you can re-enable that checkbox and add your game to the DisplayFusion Settings > Compatibility tab, and disable titlebar buttons there.

Hope that helps!
Nov 9, 2021  • #10
Quip
4 discussion posts
Picking this up.
Disabling that setting does in fact remove a 1 second stutter in Watch_Dogs, but also other games.

You could introduce a warning on hover on that setting for gamers..?
Dec 7, 2021  • #11
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
We've just released a new beta that might fix this up without needing that advanced setting. Can you try it out and let me know how it works?

Thanks!
Mar 7, 2022  • #12
Bruce Wayne93487
5 discussion posts
Quote:
We've just released a new beta that might fix this up without needing that advanced setting. Can you try it out and let me know how it works?

Thanks!


Hey Owen,

Just installed Ver. 9.9 and tested it out with a couple games on all default DF settings. There is no more stutters, game is running as smooth as it can be. Thanks for the update.
Mar 7, 2022  • #13
Slegnor
19 discussion posts
Interestingly, v10 Beta 13 caused this stutter issue for me, specifically in DayZ and Arma 3 (which use the same engine)
v10 Beta 12 was fine.
I had to add both EXE's to the compatability and disable the toolbar buttons to get it to stop grinding to a halt when the mouse was moved over a GUI element in both games.
Mar 11, 2022  • #14
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
@Slegnor Do you happen to have Arma 2, or the Arma2 dayz mod, that you could test this out with?

Thanks!
Apr 8, 2022  • #15
Slegnor
19 discussion posts
no, I dont own arma 2
Apr 9, 2022  • #16
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
We've just released a new beta with some added changes. Can you try it out and let me know if you run into any issues?

Thanks!
May 16, 2022  • #17
Slegnor
19 discussion posts
Steam 10.0 (Beta 16) update has not fixed it for me, I still require the compatability settings active for Arma3 and DayZ.

For me it needs both "Disable Titlebar Buttons (this application only)" and "Disable Application Hooks (this application only)" enabled or just "Disable Application Hooks (this application only)" enabled on its own.

"Disable Titlebar Buttons (this application only)" on its own doesnt stop the freezes like it fixed it for Bruce Wayne93487.
May 16, 2022 (modified May 16, 2022)  • #18
Mettalknight
3 discussion posts
Stuttering in both 9.9 and Beta 16. Beta 16 seems to make me stutter even worse though.
May 17, 2022  • #19
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
@Slegnor Okay interesting, thanks for the feedback.

@Mettalknight Do those two compatibility settings fix it up for the game you're having issues with?

Thanks!
May 17, 2022  • #20
Neoony
2 discussion posts
Finally there is an answer to this issue

I had the same thing happen in Arma 3
Whenever I move my mouse in the UI
(in main menu or in the map, whenever there is visible ingame mouse)
It would basically put the game into a complete stop, down to 0 FPS
The more rapidly I moved the mouse, the worse
(but it was still possible to do things, just very annoying)

I searched for a long time, found stuff about mouse polling rate and arma and all kinds of other stuff.
Nothing worked.

Now I found this.
And it is indeed DisplayFusion.

Currently on DisplayFusion Pro 10.0 Beta 16 (but it was like this for a long time)

Start Arma 3
BattlEye blocks the hook
https://i.imgur.com/ZpNDbft.png
Then the mouse issue happens.

Go to DisplayFusion settings compatibility and add arma3_x64.exe
Disable Application hooks
https://i.imgur.com/vhu07yN.png
No more mouse issue.

Big Thanks!

It would be lovely if this got fixed for everyone.
(e.g. disable hooks for arma3_x64.exe and arma3.exe for everyone by default perhaps?)
Especially because its not exactly clear that DisplayFusion might even cause such issue in some game
May 27, 2022 (modified May 27, 2022)  • #21
Neoony
2 discussion posts
I forgot to mention.

My TitleBar buttons are not enabled.
May 27, 2022  • #22
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've reached out to Battleye to see if they can whitelist our hooks. We're also going to investigate further to see if there's anything we can do from our end to prevent this issue.
Jun 1, 2022  • #23
Was this helpful?  (4)  (-)