Title

Message

Confirm

<< DiscussionsReply

DisplayFusion Pro 9.7.1 Bug - Same Wallpaper On Both Displays

Luke64
1 discussion post
Hey, as the title says, I'm having a bug with version 9.7.1 where the same wallpaper is used across both of my displays. This is in spite of the background settings being set to "Use a different image for each monitor" and the Wallpaper preview showing two different wallpapers being used.

I've tried restarting, changing the wallpaper settings, and updating the monitor configuration settings. Nothing has worked. I'm here to both report the bug, and see if anyone knows how to fix it. If you have any ideas, I'd love to hear them, thanks!
• Attachment: bug report 1.PNG [231,582 bytes]
bug report 1.PNG
bug report 1.PNG
• Attachment: bug report 2.png [3,498,642 bytes]
bug report 2.png
bug report 2.png
Dec 30, 2020 (modified Dec 30, 2020)  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Luke,

Strange, is this happening will all wallpapers, or just that one in particular?

Thanks!
Dec 31, 2020  • #2
Country Computers
1 discussion post
Same problem as OP same version 9.7.1.

Only seems to happen when computer wakes from sleep, fixes itself after cold start or reboot.
Jan 1, 2021  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Is it happening for your wallpapers, or certain ones in particular?

Thanks!
Jan 5, 2021  • #4
Combatchase
3 discussion posts
I unfortunately have the same issue. The issue was on version 9.7.1 and I was hoping it would be resolved after updating to 9.8 but no luck. The Wallpaper preview looks as expected but the actual wallpaper is displayed as the center image on all screens. Image attached for reference.

The slideshow option checked for each monitor, all set to use a different image for each and I made sure to add the wallpaper folder to each monitor individually. This setup was working correctly for 3+ years and it seems to have just bugged out sometime in the last month or two for me.
• Attachment: Bug Report 1.png [4,687,172 bytes]
Bug Report 1.png
Bug Report 1.png
13 days ago  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Does the issue persist if you set the wallpaper to span in the Windows Display settings?

Thanks!
13 days ago  • #6
Combatchase
3 discussion posts
Yes, same issue where it only displays the image on monitor 1 for all screens.
• Attachment: Bug Report 2.png [9,091,662 bytes]
Bug Report 2.png
Bug Report 2.png
13 days ago  • #7
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Interesting, DisplayFusion uses the Windows API to set the wallpaper, so if it's happening with the Windows Display Settings, then that's why it's happening with DisplayFusion as well.

Did you happen to have any Windows updates around the time the issue started?

Thanks!
12 days ago  • #8
Combatchase
3 discussion posts
The last windows update broke my ability to view previously installed updates so I'm unable to check.

I did however seem to correct the problem while trying to solve that issue. While in the msconfig services tab I disabled the below 3 services I didn't recongnize, rebooted and then it started working. I re-enabled each one and restarted after each. They're all back on now and DisplayFusion seems to working properly again.

> Disabled/Re-enabled Services:
CAM Service - Manufacturer: Unknown (found out its from NZXT software)
EABackgroundService - Manufacturer: Electronic Arts
Nahimic service - Manufacturer: Nahimic (This appears to be from Asus)
12 days ago  • #9
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Interesting, glad to hear you got it working, and thanks for sharing your solution!
12 days ago  • #10
Was this helpful?    
<< DiscussionsReply