Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

DisplayFusion + Win7 + DirectX issue?

Avatar from Gravatar.com
spockdude
2 discussion posts
I am trying to track down an issue with DirectX on a Win7 64-bit box. When attempting to install Forged Alliance, the install logs show that the DirectX install failed. Since the game is on the Windows 7 compatibility list, I wouldn't expect it to have any problems. I then tried installing the DirectX SDK (someone else says that fixed their issue), that install failed too with a S1023 error code.

Have there been any reports of DisplayFusion interfering with DirectX updates on Windows 7? Since DisplayFusion is the only thing "special" about this Windows 7 box, it has me wondering if that could be it.

This is with DisplayFusion v3.3.0.

Thanks...
Apr 15, 2011  • #1
Avatar from Gravatar.com
zAlbee
32 discussion posts
Did you try exiting DisplayFusion? Does the problem still occur after that?
Apr 15, 2011  • #2
Avatar from Gravatar.com
TheCyberShocker
26 discussion posts
You got beta 8 right? if no try updating see what happens.
Apr 15, 2011  • #3
Avatar from Gravatar.com
spockdude
2 discussion posts
Thanks for the ideas, guys. I tried beta 8 and exiting out of DF first, but those things did not help. I did, however, find the solution. Here was the error from my c:\windows\Logs\DXError.log (mostly just posting this part to help out other people who might be getting the same error):

Quote:
[04/18/11 09:51:11] module: dxupdate(Jun 2 2010), file: dxupdate.cpp, line: 5725, function: DirectXUpdateInstallPlugIn

Failed API:SetupIterateCabinet()
Error:(5) - Access is denied.

Unable to iterate through C:\temp\Dec2006_d3dx10_00_x64.cab. The file may be damaged.


I know it wasn't really a damaged cab file as I tried several different ways of installing directX with the same results (from game CD, off Microsoft's site, using the SDK version, or the June 2010 version, etc.) The "Access is denied" part was obviously the real problem, but since I was already running with admin privs, I was a bit stumped.

After doing some more searches, I found someone that resolved the issue by disabling Windows Defender. I tried that, which didn't fix the issue, but then I noticed that ClamAV was also enabled. I disabled that as well, and it fixed it. So, it's possible that Windows Defender also had to be disabled too, but I forgot to try re-enable it before attempting it. So, if anyone else comes across this issue, try disabling both.

Side note... as far as I can tell, DisplayFusion had nothing to do with this issue, and I love DisplayFusion, btw. :-)
Apr 18, 2011  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Glad to hear you were able to get the issue sorted out, and that you like DisplayFusion too :)

Thanks!
Apr 21, 2011  • #5
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply