Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Dual Monitors flip backgrounds

User Image
VStarkwell
2 discussion posts
Hi guys,

I have a main computer monitor hooked up thru DVI with the 2nd DVI output hooked up to my receiver so I can watch videos on my TV.

Unfortunately, when I turn on the receiver/TV my computer recognizes the TV as the 2nd monitor but Displayfusion recognizes it as the first monitor and the main LCD as the 2p monitor.

Therefore, the settings are reversed. The wallpaper settings for my LCD are applied to my TV. Is there a fix for this? It didn't always happen and for a while it worked but not it is starting to give me problems again.

Here is a copy of some of the Log:

Code

***** Monitor 1 (Primary:False ~ Attached:True) ********
Video Card: NVIDIA GeForce 9800 GT
Monitor: Generic PnP Monitor
Device: \\.\DISPLAY1
Bounds: {X=1920,Y=0,Width=1920,Height=1080}
WorkArea: {X=1920,Y=0,Width=1920,Height=1080}

***** Monitor 2 (Primary:True ~ Attached:True) *********
Video Card: NVIDIA GeForce 9800 GT
Monitor: Dell 2407WFP (Digital)
Device: \\.\DISPLAY2
Bounds: {X=0,Y=0,Width=1920,Height=1200}
WorkArea: {X=0,Y=0,Width=1920,Height=1200}

***** Monitors by Bounds *******************************
2, 1
Force Order: None

***** Screens ******************************************
Count: 2
Point Min: {X=0,Y=0}
Point Max: {X=3840,Y=1200}
Total Size: {Width=3840, Height=1200}
ActiveDesktop: False

***** Screen 1 *****************************************
Name: Generic PnP Monitor @ NVIDIA GeForce 9800 GT
Bounds: {X=1920,Y=0,Width=1920,Height=1080}
MoveH: 0
MoveV: 0
Scaling: 100.00%

***** Screen 2 *****************************************
Name: Dell 2407WFP (Digital) @ NVIDIA GeForce 9800 GT
Bounds: {X=0,Y=0,Width=1920,Height=1200}
MoveH: 0
MoveV: 0
Scaling: 100.00%


I see where it says "Force Order" in the log but I can't find a setting. Windows keeps the LCD the main monitor though (when I click identify the LCD shows up as '1' and the TV as '2').

BTW, the computer is Windows 7 x64 with the latest Nvidia drivers.

Thanks!!
Jun 27, 2010  • #1
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
The "force order" setting doesn't force the monitor numbers, sorry. Unfortunately with Windows 7 the monitor numbering can be a bit off. :( The only thing I can think of is to reverse the location they are plugged in on the back of your video card. This way, DF should always recognize your main LCD as the first monitor. :) I had to do this on one of my test machines and it has worked perfectly ever since. :)
Jun 30, 2010  • #2
User Image
VStarkwell
2 discussion posts
Thanks for the help.

Unfortunately, switching ports didn't help. I put the ports back and it seems to fix itself once I turn the TV off and sometimes it doesn't even give me any problems.

I'll just live with it. Thanks again.
Jul 1, 2010  • #3
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Sorry I can't provide a more concrete solution, Windows 7 is terrible at maintaining monitor IDs. :(
Jul 5, 2010  • #4
Was this helpful?  Login to Vote(-)  Login to Vote(-)