Save up to 50% off any of our desktop apps in our 2021 spring sale, including
DisplayFusion, ClipboardFusion, FileSeek, LogFusion, TrayStatus, and VoiceBot!

Title

Message

Confirm

<< DiscussionsReply

Error when changing monitor profiles

Ferro Giconi
5 discussion posts
I'm getting an error when trying to use a saved monitor profile to change the orientation of screens:

Code



Here's what I've tried so far:
-Uninstall, delete all settings, and reinstall DisplayFusion to the latest release version, recreate my profiles (multiple versions over the last year. I don't know exactly which versions I used but they were various 9.6 and 9.7 versions. All had the same error starting to show up again a few hours after reinstall.)
-Update displayfusion to the latest beta version, 9.7.1 beta 10
-Used Display Driver Uninstaller to uninstall my graphics drivers, including Intel, AMD, and nVidia to remove traces of previous drivers in case the old intel drivers were interfering. Then reinstalled nVidia drivers version 460.89

I only found one thing that works temporarily. If I delete all my monitor profiles then recreate them, they start working for a few hours, but then I start getting that error again.

Any ideas what else I could try?
• Attachment [protected]: DisplayFusionDebugInfo.zip [28,504 bytes]
Dec 27, 2020  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
That's about everything I would recommend to try as well. Would you be able to send a full debug log?

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the error and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!
Dec 29, 2020 (modified Dec 29, 2020)  • #2
Ferro Giconi
5 discussion posts
It's been a few days since I updated to 9.7.1 beta 10 and recreated the profiles, and no error yet. Maybe I created this post a bit preemptively, because I only created it a couple hours after updating to 9.7.1 beta 10, convinced that updating to that version would produce errors soon after like the previous updates did.

If it happens again, I'll be sure to do as you recommended with debug logging. But I'm hopeful that whatever changed in this version fixed it enough that the error won't come back.
Dec 31, 2020  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, thanks for following up!
Jan 6, 2021  • #4
Was this helpful?    
<< DiscussionsReply