Title

Message

Confirm

<< DiscussionsReply

High CPU usage when NuSphere PhpED is running

Olli81
12 discussion posts
When my PHP IDE NuSphere PhpED is running the DisplayFusion.exe process is using permanently between 15% and 25% (spikes up to 30%)
As soon as I close PhpEd CPU usage drops to 0%-2%

I'm using a Core i7-4720HQ with DisplayFusion 9.8

In compatibility settings I already disabled hook and all other settings with additon "only this application"

DebugInfo is attached

As I read in this thread:
https://www.displayfusion.com/Discussions/View/high-cpu-usage/?ID=55fed1ce-da61-421f-a248-c4018a54ca3f#4
I disabled all 3 hooks (applications, polling, and shell) in advanced settings.

There was only a slightly change in CPU usage (reduced to 15% - 20%)
• Attachment [protected]: DisplayFusionDebugInfo.zip [102,446 bytes]
Jul 30, 2021 (modified Jul 30, 2021)  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Can you run through the DisplayFusion Settings window and try disabling some of the main features (Titlebar buttons, Triggers, Multi-Monitor Taskbars, etc.) and see if anything causes a drop in usage?

Thanks!
Aug 4, 2021  • #2
Olli81
12 discussion posts
Thank you for your reply.

Disabling "Multimonitor Taskbars" and usage drops to normal 0% - 2%.
Sub-Options make no difference.

No effect for other settings.

Also no difference if the PhpED window is placed on the windows taskbar or DP taskbar.

Beside that my configuration:
1 Monitor connected (3440x1440px)
1 vertical split defined at 1520px (gives left 1520px | right 1920px)
Right as "main" working area (windows taskbar)
Left as "secondard" (DP taksbar)
PhpED windows is always on right side / main area

My taskbar settings screenshot attached.
Also full export of DP settings.
• Attachment [protected]: 2021-08-04 23_42_49-Settings _ DisplayFusion Pro on Steam 9.8.png [14,832 bytes]
• Attachment [protected]: settings.zip [44,789 bytes]
Aug 4, 2021  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Interesting, if you re-enable your second taskbar, can you right click an empty spot on it, and head to "Multi-Monitor Taskbar", and then disable the settings listed there to see if we can narrow it down further?

Thanks!
Aug 5, 2021  • #4
Olli81
12 discussion posts
None of the settings made a difference.
Even if I disabled the taskbar through the right click menu (MM taskbar => Position => Disabled) there war no change (in DP settings "Enable MM Taskbars" was still active and I made it visible again by "Enable all Taskbars)
Aug 8, 2021  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Interesting, has this only started happening since updating to v9.8? Also, out of curiosity, if you disable your current advanced setting for taskbar animations, does that help at all?

Thanks!
Aug 9, 2021  • #6
Olli81
12 discussion posts
I'm not sure. I started using my laptop for every day work a few weeks ago.
All animations you can disable in windows I already disabled.
In my opinion any kind of animation is just a waste of time.

I saw today that after a reboot and starting all my programs, for a time (maybe 15 minutes) everything was fine and CPU went up later on.
I just realized that thing here is still running with Win10 Version 1703.

Thanks for your help. I guess the something in the system must be messed up in general.
Beside that I just bought a new desktop and after moving all data and settings I'll give the laptop a fresh install. Like in the good old days, problem will hopefully be solved afterwards.
Aug 9, 2021  • #7
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Sounds good, if you run into any issues with your new install, just let me know.

Thanks!
Aug 10, 2021  • #8
Was this helpful?    
<< DiscussionsReply