Save up to 50% off any of our desktop apps in our 2021 spring sale, including
DisplayFusion, ClipboardFusion, FileSeek, LogFusion, TrayStatus, and VoiceBot!

Title

Message

Confirm

<< DiscussionsReply

MAJOR ISSUE WITH LAST 2 betas!

Emulated
5 discussion posts
I run a 2080 ti and 1x 1060... the last update causes huge microstutter every 5- 10 secconds I just spent 3 hours tearing my computer a part in a drunken stuper and hardware configing every possiable scenario... only to the point where I got both cards back in the micro stutter continued, I was about to buy a $700 power supply but found no v drop so I dove deeper... it turns out the last 2 display fusion betas are causeing micro stuttering hugely between multiple video cards...

please fix this ASAP!!!!!!

major issue.
Apr 9, 2020  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you send us a debug log for this issue?

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log
Apr 10, 2020  • #2
Bill Y.-C. Su
8 discussion posts
I have similar mouse lag problem after applying update to 9.7 beta 9. When I move the cursor, the cursor lag is noticable and become normal (no lag) after the DisplayFusion was exited. Also tried 9.7 beta 10, mouse lag is still happening but better than beta 9. I didn't experience this phenomenon in 9.7 beta 8 and before.
Now what I could do is turn off DisplayFusion and wait for new beta version release. Hope the new beta version will come out soon.
Thank you.
Apr 17, 2020  • #3
Viper0000
6 discussion posts
Quote:
I run a 2080 ti and 1x 1060... the last update causes huge microstutter every 5- 10 secconds I just spent 3 hours tearing my computer a part in a drunken stuper and hardware configing every possiable scenario... only to the point where I got both cards back in the micro stutter continued, I was about to buy a $700 power supply but found no v drop so I dove deeper... it turns out the last 2 display fusion betas are causeing micro stuttering hugely between multiple video cards...

please fix this ASAP!!!!!!

major issue.


same, 2060 laptop and 1080ti desktop
Apr 17, 2020  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Viper: Could you send us a debug log for this issue?

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log
Apr 17, 2020  • #5
Viper0000
6 discussion posts
happens many times while moving my mouse around in circles on the windows desktop for a few minutes.

using the old december release version until this is fixed.
• Attachment [protected]: DisplayFusionDebugInfo.zip [52,648 bytes]
Apr 19, 2020 (modified Apr 19, 2020)  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
With Beta 10, if you enable the "Disable Application Hooks" option in the Settings > Advanced Settings (so that it's set to hooks disabled), does that make any difference?
Apr 20, 2020  • #7
Viper0000
6 discussion posts
nope, only downgrading to the december version

that also breaks the wrap mouse horizontally feature that i use
Apr 20, 2020 (modified Apr 20, 2020)  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Would you be able to help us narrow down which beta it broke in?

Could you try these two and let me know if it's broken in either one?

DisplayFusion 9.7 Beta 7
DisplayFusion 9.7 Beta 8
Apr 20, 2020  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Bill Y.-C. Su: I've moved your post to this thread, as I believe that since it started with Beta 9 for you, it's related to this issue. The one in the other thread was in 9.6.1.

Would you be able to help us confirm that it was fine in Beta 7 and 8, and broken in Beta 9/10? (9 was replaced with 10, as it had a crashing issue)

DisplayFusion 9.7 Beta 7
DisplayFusion 9.7 Beta 8
DisplayFusion 9.7 Beta 9/10
Apr 20, 2020  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
If you could also do the following tests for me, that would be great!

With Beta 10:

  • Make sure that logging is set to disabled on the DisplayFusion Settings > Troubleshooting tab.
  • If the lag is still there with logging disabled, try disabling all options on the Settings > Window Snapping tab, and the Settings > Window Management tab.

Thanks!
Apr 20, 2020  • #11
Bill Y.-C. Su
8 discussion posts
Quote:
If you could also do the following tests for me, that would be great!

With Beta 10:

  • Make sure that logging is set to disabled on the DisplayFusion Settings > Troubleshooting tab.
  • If the lag is still there with logging disabled, try disabling all options on the Settings > Window Snapping tab, and the Settings > Window Management tab.

Thanks!


Thank you for providing beta 7/8/10 versions for testing. Just tried beta 7 and 8, mouse cursor moved smoothly without lag. After installing beta 10, mouse lag happened even I follow your instructions above to turn off log function (seems not enabled by default) and all window snaping/management functions (no check mark in neither window snapping nor management tab).

If you need further information, please feel free to let me know. (Sometimes might response late, sorry!)
Apr 20, 2020  • #12
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No problem at all, thanks for doing that testing! We'll keep you posted if we need more info.

Thanks!
Apr 21, 2020  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Actually I do have another couple of questions. Is the lag consistently timed? e.g. every 5 or every 10 seconds maybe?

If you disable any of the features below, do they make any difference?

  • Multi-Monitor Taskbar
  • Alt+Tab Handler
  • Titlebar Buttons

Thanks!
Apr 21, 2020  • #14
Bill Y.-C. Su
8 discussion posts
It looks like mouse lag every (roughly) 5 seconds regularly... and mouse lag still happened after trying to turn off every functions you suggested except the last one "titlebar buttons" because I couldn't find this option. (but I didn't see any buttons on my window titlebar though...)

Furthermore, I have another finding. I pressed a key on the keyboard to type continuously, the input will be stopped for a few micro seconds every (roughtly) 5 seconds then start to send the character immediately after the short stop. It's similar to mouse lag phenomenon, but happened to keyboard text input. After unload DisplayFusion 9.7 beta 10, everything goes back to normal.
Apr 21, 2020  • #15
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Bill Y.-C. Su: Thanks, that's definitely helpful! If you set the "Disable Application Hooks" option in Settings > Advanced Settings to "Application hooks will be disabled" and restart DisplayFusion, is the mouse lag still there?

Also, could you attach a copy of your troubleshooting info?

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached
Apr 21, 2020 (modified Apr 21, 2020)  • #16
Bill Y.-C. Su
8 discussion posts
Just tried to let "Application hooks are disabled", but mouse lag still happened.

Debug info is enclosed.
• Attachment [protected]: DisplayFusionDebugInfo.zip [25,247 bytes]
Apr 21, 2020  • #17
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok awesome, thanks for trying that! We have an idea of what might be causing this, and we're making some changes for Beta 11. We'll let you know as soon as it's ready to try out.
Apr 22, 2020  • #18
Slyck
1 discussion post
Hello! I joined the forum just to add another voice to the mix, in case it is useful. I've been searching for a solution to this issue for quite a while, since I'm experiencing the exact same thing. It's forced me to stop using DF on my laptop as the mouse/keyboard hiccup every five seconds is just too intrusive. In Task Manager I can see the DF CPU usage jump from a fraction of a percent to 2.5% every time this happens.

I'm happy to provide any additional troubleshooting info, but my system is also running two graphics cards: an integrated Intel UHD Graphics 630, and an NVIDIA Quadro P1000. This is on a Dell Precision 7530 running Windows 10 Enterprise. Thanks!
Apr 23, 2020  • #19
SurfRat
40 discussion posts
Yesterday I played Fallout 4 (single 1080ti) and noticed a lot of micro stutter while panning around. I tracked it down to DF 9.7 Beta 10. Exiting DF or disabling application hooks solved the problem.
May 2, 2020  • #20
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've just released a new DisplayFusion beta version and this issue should be all fixed up. Please let us know if you run into any trouble after updating.

Thanks!
May 8, 2020  • #21
Collin Chaffin
62 discussion posts
It's not resolved. The "stutter" is actually 100% of single core being pegged constantly as of 9.7 betas on every WIN7x64 system/hardware/config I've tested.
Collin Chaffin's profile on WallpaperFusion.com
May 16, 2020  • #22
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Colin: We've found the CPU issue in Windows 7, it's different than the Win 10 issue in this thread, but we'll have it fixed up for 9.7 Beta 15
May 20, 2020  • #23
Was this helpful?    
<< DiscussionsReply