Title

Message

Confirm

<< DiscussionsReply

Middle Mouse Button lagging to swap monitors

InnerSpike
2 discussion posts
Very recently, for whatever reason, whenever I use my middle mouse button to swap what monitor a window is on, it takes 5-10 seconds before the window will switch. Clicking the icon and using ctrl+win+x work fine and will swap the window immediately. But for whatever reason, using the middle mouse button there's a bit of lag. If I click multiple times, after the 5-10 seconds the window will swap monitors that many times. So if I click 4 times, after 5-10 seconds the window will swap, swap, swap, swap quickly.

Side note: the middle mouse button works for everything else for other programs and windows with no problems. It's only DisplayFusion
Jan 22, 2021 (modified Jan 22, 2021)  • #1
Mathis Arondeau50559
1 discussion post
I have the exact same problem, which is very annoying since it's one of the features i use the most
Jan 23, 2021  • #2
sysrage
2 discussion posts
This is happening to me, also. It's a good 1-2 second delay.
Jan 24, 2021  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Can you try updating to our latest beta and see if the issue persists? Here's the link: https://www.displayfusion.com/Download/Beta/

Thanks!
Jan 26, 2021  • #4
Hollo
57 discussion posts
The same started happening to me today and I'm using beta4 since its release.
Jan 27, 2021  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Is this happening when trying to move any window, or is it happening with specific application windows?

Thanks!
Jan 27, 2021  • #6
Hollo
57 discussion posts
Once it's started, it was happening with all windows, regardless of application, display, moving direction and windowed/maximized state.
DF restart didn't help, PC restart fixed it temporarily.
Jan 27, 2021  • #7
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Could you send me over a debug log? Here are the steps:

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!
Jan 28, 2021  • #8
Hollo
57 discussion posts
Hi,

I can't reproduce the issue because I have no clue what brings it on. Today it started happening out of the blue after ~6hrs of uptime seemingly without any reason, I wasn't doing anything out of the ordinary. Again it could only be fixed with a PC restart and after that I've tried to redo everything I've been doing for the preceding hour but couldn't make the problem appear.
Also I can't enable logging, GUI says Error: Result is invalid. [System.Exception]
(although in the exported zip, there are two .log files which have content but the html just contains the same error, I'll leave it on if the textual debug log is enough)
Jan 29, 2021 (modified Jan 29, 2021)  • #9
InnerSpike
2 discussion posts
I can't reproduce this consistently either. It's intermittent. Since creating this thread, the problem went away after an hour. Since then I've only experienced it once for maybe a few hours. I didn't turn any programs off, restart my machine, change any settings in DF.
Jan 29, 2021  • #10
Hollo
57 discussion posts
I can reproduce this with an ahk script which sends a key down event only when a specific window is active.
- The issue stops happening only when a key up event for the same key is received in any window.
- Not a bug with the application: the issue persists even if the application quits.
- Not a bug with ahk: the issue persists when the script is restarted or even ahk is completely closed.
- Not key specific: reproducible bound to any hotkey, for any key that the key down event is being sent for (including special keys like Tab and Capslock).
- Not application specific: reproducible with any application.

I'm not sure this is the only thing that triggers this problem, this is just the one I could isolate and reliably reproduce it with.

Hope this helps. I can try to make a log if it's still needed.
Feb 2, 2021  • #11
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

A debug log would be great if you could grab it. Just to confirm, this is happening on the latest beta version of Display Fusion?

Thanks!
Feb 2, 2021  • #12
Hollo
57 discussion posts
Hi,

The .html still shows the error message only but the actual log is in there.
I did the repro with binding Capslock to Tab down event if notepad.exe is active (just for reference, behaves the same with any other application and key).
I'm using 9.7.2b4.

Hope this helps!
• Attachment [protected]: DisplayFusionDebugInfo.zip [42,104 bytes]
Feb 2, 2021  • #13
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Thanks for sending that over! We should have this fixed up in our next beta, so we'll be sure to let you know once it's been released.

Thanks!
Feb 4, 2021  • #14
Hollo
57 discussion posts
Hello,

Beta5 seems to have fixed this, at least for the use case I reproduced it with.

Thanks!
Feb 10, 2021  • #15
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Glad to hear! If the issue comes back, just let us know.

Thanks!
Feb 10, 2021  • #16
Was this helpful?    
<< DiscussionsReply