Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Mouse lag/skipping in fullscreen games. Windows 7

Avatar from Gravatar.com
hyperwired
2 discussion posts
Windows 7 (RTM, MSDN)
DisplayFusion 3.1.4

I used to run Ultramon when I had XP, but installed DF recently when I moved to Windows 7.

As soon as I had installed DF, games (listed below) became very choppy whereas beforehand they were very smooth. Interestingly there was not much of a difference in FPS. The choppiness greatly affected mouse input making the mouse 'skip' inconsistently. That is, the rate of movement jumps drastically at random moments, and is generally inconsistent.

I tried checking my mouse, but got the same skipping with 3 mice (with corresp drivers installed):

[list]
  • Razer Deathadder
  • Logitech mx518
  • Razer Lachesis
  • [/list]

    ... using a Razer Destructor mousepad. Since all mouse skipped, I next did software isolation tests:

    [list type=decimal]
  • standard bootup environment. DF running
  • standard bootup environment. no DF running
  • bare essentials with all background processes closed. DF running
  • bare essentials with all background processes closed. DF not running
  • many extra background processes. DF running
  • many extra background processes. DF not running
  • [/list]

    The corresponding results of this were:

    [list type=decimal]
  • skipping
  • smooth
  • skipping
  • smooth
  • skipping
  • smooth
  • [/list]

    This behaviour was consistent with the following fullscreen games:
    [list]
  • Team Fortress 2 (steam)
  • Counter Strike: Source (steam)
  • Call of Duty 4 (non-steam)
  • [/list]

    I have installed the latest videocard drivers (nvidia 8800GTS 512mb), and directx drivers (DirectX 11), and the Windows is genuine and up to date.

    I am running two monitors at 60Hz:
    [list type=decimal]
  • 1680x1050
  • 1280x1024
  • [/list]

    I can only conclude that DisplayFusion is the culprit here. Please find a fix for this behaviour because I dont want to go back to Ultramon since it has poor Windows 7 support
    Oct 8, 2009  • #1
    Jon Tackabury (BFS)'s profile on WallpaperFusion.com
    Make sure the DisplayFusion setting "Pause System Hooks when a fullscreen program is detected" on the "Options" tab. Let me know if this solves the problem, and if not we can try a few more things.
    Oct 8, 2009  • #2
    Avatar from Gravatar.com
    hyperwired
    2 discussion posts
    Quote:
    Make sure the DisplayFusion setting "Pause System Hooks when a fullscreen program is detected" on the "Options" tab


    That seemed to fix the skipping. thanks. :-)
    Oct 10, 2009  • #3
    Jon Tackabury (BFS)'s profile on WallpaperFusion.com
    Excellent - thanks for the follow-up.
    Oct 10, 2009  • #4
    Avatar from Gravatar.com
    kalzn
    1 discussion post
    Hello, I have exactly the same problem as hyperwired, the mouse skipping apears in fullscreen games like hyperwired. Only one thing is difference. I just use one single monitor 1680x1050. Do you have some other ideas about how i can solve the problem? please let me know..
    Jan 9, 2010  • #5
    Jon Tackabury (BFS)'s profile on WallpaperFusion.com
    @kalzn: Have you tried this suggestion yet:
    "Make sure the DisplayFusion setting "Pause System Hooks when a fullscreen program is detected" on the "Options" tab"

    What version of DisplayFusion are you using? If you're feeling adventurous, can you give the new beta a try and see if that helps out? It has a number of hook related improvements:
    http://www.binaryfortress.com/Forum/index.php?topic=1310.0

    If none of these work, can you post all the information from the Troubleshooting tab in the DisplayFusion Settings window? Thanks!
    Jan 10, 2010  • #6
    Was this helpful?  Login to Vote  Login to Vote
    << DiscussionsReply