Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Multi-Monitor Taskbar & RDP Full Screen Window

Avatar from Gravatar.com
Ben Richards
4 discussion posts
Been using DisplayFusion for a long time now. It's great and I love it.

However I've always ran into the following issue which drives me nuts on occasion:

When I open a new RDP connection in full screen on my non-primary monitor, the task bar disappears for a second (and I can see the start menu in the RDP session, which is the desired behavior) but then appears again. I know I can set the multi-monitor taskbar to auto-hide but that has other implications I'm not happy with. Is there a way around this so the multi-monitor taskbar does not appear on top of my full screen RDP window? A way to hide (not disable, I know about that option) when using a full screen RDP window?

Thanks a bunch! Keep up the good work!
Boyan
Oct 12, 2011  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
For me, the taskbar does stay behind the RDP window. Which version of Windows/RDP are you using?
Oct 13, 2011  • #2
Avatar from Gravatar.com
Ben Richards
4 discussion posts
I'm using Windows 7 x64, RDP is v6.1.7601.17514.

I am attaching a screenshot. It doesn't seem to be a problem constantly. I played with the remote session settings and if I set "Apply Windows Key Combinations" to the remote session (full screen or not), it seems to work better.

Maybe something to put in your F.A.Q?

Boyan
• Attachment: RDPScreenshot.png [15,200 bytes]
RDPScreenshot.png
RDPScreenshot.png
Oct 14, 2011  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
The remote key combinations shouldn't have anything to do with it, but I'll try it out anyways. In the meantime, could you do the following?
  • Enable debug logging on the Troubleshooting tab in DisplayFusion
  • Reproduce the issue
  • Email me (support@displayfusion.com) the info from the Troubleshooting tab when the issue is present
  • Also send the %APPDATA%\DisplayFusion\DisplayFusion.log (Can be found by clicking the Open Log button on the Troubleshooting tab)
Thanks!
Oct 14, 2011  • #4
Avatar from Gravatar.com
Danny Aponte
6 discussion posts
Quote:
I played with the remote session settings and if I set "Apply Windows Key Combinations" to the remote session (full screen or not), it seems to work better.


This makes some sense... I would imagine that if you hit the Windows key, and RDP is not passing the key combinations through, then DF's toolbar will register the keypress, bring up the DF Start Menu and in turn pull the DF Taskbar on top of the RDP window.

Boylan, I would assume that clicking back into the RDP window doesn't pull RDP over the DF Taskbar again? This would probably be considered a bug.

Have you tried clicking the DF taskbar (to completely give it focus) and then click on the RDP window? That works to troubleshoot general Windows "Always on Top" issues.
Oct 26, 2011  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
In an effort to cleanup the DisplayFusion Discussions, this topic is being marked as Complete as it hasn't received a response for more than 30 days. If you're still having trouble and would like some help, just let me know!

Thanks!
Nov 29, 2011  • #6
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply