Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

"Reload Taskbar when Fullscreenapplication is detected"-Problem

Avatar from Gravatar.com
Tim35
7 discussion posts
Hi,

My new Problem refers to http://www.displayfusion.com/Discussions/View/switching-primary-monitor/?ID=5ca9fbbe-88f5-4a2b-b880-3621ad7cd0e2

This option works like a charm with fullscreen apllications which allows to bring the taskbar in front of them (for example "Media Portal").

Most of the fullscreen games dont allow this. If you want to use the desktop or the taskbar while gaming you have to switch with 'alt+tab' hotkey. No problem so far, we have to live with that (stupid gaming devs (; ).

But if the 'reload Taskbar when Fullscreen..etc' option is activated youre not able to Switch back to the game.
After 'exiting' the desktop and maximize the game again DisplayFusion seems to detect a new fullscreen application and reloads the taskbar. This prombts some games to minimize again (for example "Company of Hereos"). So everytime you try to maximize the game it's automatically minimized again.
I know the problem lies more in how games handle the fullscreen but maybe you have a nice solution for me.
Maybe some way to detect problems with maximizing and prevent displayfusion to reload in this situtation or a software-blacklist for the reload function(Ugly solutions but better then nothing). I'll bet you have better ideas then me
Thanks in advance and thanks for this great Software.

Regards

Tim
Jun 12, 2012  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've actually added a HotKey in the latest 4.1.0 Beta versions that will prevent the game windows from being minimized when losing focus, so perhaps this will help solve both issues

Just set a key combination for the "Prevent Window Deactivation" HotKey and apply the settings. Then, before you launch the game, press the key combination. After you're done playing the game, press the key combination again to turn it off.

Please let me know how that works out.

Thanks!
Jun 13, 2012  • #2
Avatar from Gravatar.com
Tim35
7 discussion posts
ok cool, for most if my games this works. "Company of heroes" switches to windows-mode. But thats ok. Its playable.
Thanks for your help.
Jun 15, 2012  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Excellent, no worries! You could create a Compatibility rule in DisplayFusion for Company of Heroes, and enable the "Pause Multi-Monitor Taskbars while this Application is running" option. That should keep the taskbar from doing any funny business while Company of Heroes is open
Jun 15, 2012  • #4
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply