Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Restore Settings migrated from old computer resets license from Pro to not Pro

User Image
sfwrtr
273 discussion posts
Keith,

I am in the process of migrating from one Windows 10 machine to new Windows 10 hardware. I used the My Binary Fortress Account fields to install my license. This works. However, when I take the .reg file exported on the old hardware and use Restore Settings on the new hardware, it wipes the Pro license. (I do get a UAC prompt.) I see a (+Pro) link in triggers, for example.

I'm attaching a protected file attachment with my license account email address to be safe. It's different, than the email address.

Some guidance here would be appreciated. I can turn on the debug logging and try again if you direct me to do so.

-Robert
• Attachment [protected]: df account email.txt [58 bytes]
Jan 25, 2017  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you attach a copy of your settings backup as well?
Jan 25, 2017  • #2
User Image
sfwrtr
273 discussion posts
Here's the requested backup.
• Attachment [protected]: DisplayFusion Backup (2017-01-24 @ 16-38, 8.1.2.0, RBLUM-HQ-WIN7).reg [213,426 bytes]
Jan 26, 2017  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! When I restored your backup file here, it worked correctly and kept the license info. If you try again, do you run into the same issue?
Jan 31, 2017  • #4
User Image
sfwrtr
273 discussion posts
Yes, it failed again.

EDIT: Added the new settings file.
• Attachment [protected]: DisplayFusion Backup (2017-02-07 @ 08-20, 8.1.2.0, RBLUM-HQ-WIN7).reg [213,350 bytes]
Feb 7, 2017 (modified Feb 7, 2017)  • #5
User Image
sfwrtr
273 discussion posts
More detail: This a total failure to import the settings. All my caption bar buttons are missing, not just the license, and it looks like there are defaults instead.

So...

I enabled maximal logging on the old machine and exported the settings again, then turned off logging there.

I enabled maximal logging on the new machine then restored the settings there, then turned off the logging there.

Attached are both the logs. Hopefully you can debug this annoyance.
• Attachment [protected]: DisplayFusion New Machine.log [2,584,548 bytes]
• Attachment [protected]: DisplayFusion old machine.log [7,035,293 bytes]
Feb 7, 2017  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks for the logs, unfortunately there's nothing suspicious in them :(

Could you try this instead?
  • Exit DisplayFusion
  • Double-click the backup file
  • Choose Yes when prompted to import
  • Launch DisplayFusion after the import is complete
Feb 7, 2017  • #7
User Image
sfwrtr
273 discussion posts
Ok, you are going to LOVEthis one. I received you suggestion from my other open problem report to try older version of the product and it proved diagnostic for this one.

I downloaded the oldest version after first exporting the settings I had from the currently GA version. I then installed version 8.0; it verified my PRO license and it came up vanilla. I tried restoring my 1/24 .reg file and it failed.

So, thinking that maybe the whole restore process was FUBAR, I tried restoring the settings .REG file I had just exported to my desktop.

It worked. It even restored my license!

I asked myself, as I learned to when I was in tech support, what was different?

Other than .REG content and the exe version, the only other difference was location. All my configs from my old computer are stored on a mapped drive on the old machine. The new config was stored on the desktop of my new machine.

I copied the 1/24 configuration from my mapped drive to my desktop and restored it, and, no suspense here, it worked! :o It even installed my pro license and displayed all my tool bars buttons, even going to the point of complaining about missing wallpaper.

I will go back to the GA version and see if this oddity holds true, but I expect it does.

The problem appears to be with restoring settings from a mapped drive, in this case assigned to drive B: Technically, it is a peer to peer mapping, not a mapped LAN drive on a server, but I think today that distinction is inconsequential, but I am including it just in case.

I will edit this reply after I reinstall the current version.

EDIT: I am now running 8.1.2. The restore of the 1/24 settings from my local desktop worked.

Oddly, it stopped applying settings when it couldn't find a missing wallpaper I had not copied to the local drive. I only had one caption bar button showing. However, all the settings were still visible when I opened the DF settings dialog. Apply didn't work until I selected an image for the wallpaper. Apply then finished restoring all my settings, including all my buttons. It appears that DF has a stop-on-exception policy for applying settings rather than skip-on-exception. Not sure which is better. Just point it out so you can think about it.
Feb 23, 2017 (modified Feb 23, 2017)  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Oh, interesting! I wonder if Windows is preventing the registry import because the .reg file is in an untrusted location. I will add this to our list to look into, thanks for sharing the details!

I'll add that issue of the settings apply stopping on the logon background fail to our list to review as well :)
Feb 23, 2017  • #9
User Image
penguinairlines
1 discussion post
Quote:
All my configs from my old computer are stored on a mapped drive on the old machine. The new config was stored on the desktop of my new machine.


Thanks for your detail! I had a similar issue today and, after finding your post, tried to execute the registry entry file. When restoring in
DisplayFusion > Settings > Options
from my NAS, the import is "successful", but seemingly nothing changes. When executing the file from the NAS, I actually get an error
Cannot import <NAS path>\DisplayFusion Backup (2022-03-07 @ 16-23, 9.9.0.0, <hostname>, SettingsWindow).reg: Error opening the file. There may be a disk or file system error.
However, when I copied the file to my local machine and executed it (with DF exited), I was then able to launch DisplayFusion and see that seemingly all of my settings were restored!

It seems that Keith Lammers nailed the issue description
Quote:
because the .reg file is in an untrusted location.
, but sadly it looks like this issue hasn't gathered enough attention over the last 5 years to warrant an enhancement to test that the file is being loaded from a local path.
Mar 8, 2022  • #10
Was this helpful?  Login to Vote(1)  Login to Vote(-)