Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

"Set next Playback audio device" not always working ?

Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
So, I wanted to switch my default audio playback device when working on my 3rd monitor or playing games, but this option in "triggers" menu doesn't always work. Sometimes it switches audio device, sometimes not.

Any idea why ? and how can I fix this issue ?
12 days ago  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you try adding a "Show Notification" action to the Trigger rule, so that you can see if it's an issue with the rule not running, or an issue with the rule running, but the audio device not changing?
11 days ago  • #2
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Quote:
Could you try adding a "Show Notification" action to the Trigger rule, so that you can see if it's an issue with the rule not running, or an issue with the rule running, but the audio device not changing?


The rest of the actions work perfectly fine. My monitor settings and other things run smoothly without any issues. It's only this specific part
11 days ago  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you send over a screenshot of the edit window for the Trigger rule?
11 days ago  • #4
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Quote:
Could you send over a screenshot of the edit window for the Trigger rule?
• Attachment [protected]: DisplayFusionSettings_2019-03-14_20-48-13.png [32,428 bytes]
• Attachment [protected]: DisplayFusionSettings_2019-03-14_20-48-36.png [31,579 bytes]
11 days ago  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! How many playback devices show up in the DisplayFusion tray menu > Audio Devices > Default Playback Sounds list?
11 days ago  • #6
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Quote:
Thanks! How many playback devices show up in the DisplayFusion tray menu > Audio Devices > Default Playback Sounds list?

Only 2 exacly like in my windows audio settings. That's why I can swap between them with this commands "previous/next"
11 days ago  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Yeah cool, just making sure :)

Strange that it's not working. Could you enable debug logging and send over the log the next time it fails to change?

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!
11 days ago  • #8
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Quote:
Yeah cool, just making sure :)

Strange that it's not working. Could you enable debug logging and send over the log the next time it fails to change?

  • On the DisplayFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!


Well so I replicated the issue just now (21:03 currently here in Poland) so it should be visible somewhere in recent 4/5 minutes or so in the logs :)
• Attachment [protected]: DisplayFusionDebugInfo.zip [85,276 bytes]
11 days ago  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! I'll send these over to our developers and let you know early next week what we are able to find out.
11 days ago  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you enable the "Logging: Enable Thread Names" option in the DisplayFusion Settings > Advanced Settings window, enable debug logging, restart DF, and send another copy of the log when it happens again?

Thanks!
3 days ago  • #11
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Basically, the switch works 2/3 times and every 2 it just fails so it's easy to replicate the issue :) hope it will somehow help

BTW. I just replicated the issue and it's 18:48 my time
• Attachment [protected]: DisplayFusionDebugInfo.zip [255,562 bytes]
3 days ago (modified 3 days ago)  • #12
Avatar from Gravatar.com
Divine Kataroshie41252
8 discussion posts
Quote:
Could you enable the "Logging: Enable Thread Names" option in the DisplayFusion Settings > Advanced Settings window, enable debug logging, restart DF, and send another copy of the log when it happens again?

Thanks!


Btw I will send more info and help troubleshooting the issue as much as possible :) But I tried to stop/play videos in the background, change quality of audio devices etc. And it seems like the issue is just random.
3 days ago  • #13
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply