Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Taskbar auto-hide per monitor?

User Image
Mark S.
26 discussion posts
Is there a way to configure the multi-monitor taskbar to auto-hide on certain monitors but leave it to display all the time on other(s)? I have a multi-monitor setup in which I would like 3 of the monitors to auto-hide, but have the 4th display the taskbar all the time. If not, can I suggest that as a future feature? Thanks!
Oct 6, 2022  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
You can do this, yep! For each taskbar you want to auto-hide, right-click the taskbar, then navigate to Multi-Monitor Taskbar > Auto-Hide > Enabled.

That's a per-taskbar setting so you can do it selectively. Also note that for the tasbkar on the primary monitor, you'll have to control the auto-hide settings with the Windows taskbar settings.
Oct 6, 2022  • #2
User Image
Mark S.
26 discussion posts
Hi! Thanks for the quick response.

I tried this previously, which is what confused me. The Windows taskbar is set to auto-hide. I have a DisplayFusion taskbar set to Enabled, shown with the Windows taskbar. This one has the desired and expected behavior. No space reserved where the taskbar is/would be and it auto-hides until either I hover over it, or the Windows taskbar. I used the Disabled option on another monitor, and it reserves screen real estate where it should be displaying, however it too auto-hides until I hover over it. It does not show when Windows taskbar is activated which is expected. (This is what made me assume that I was using the options incorrectly/feature wasn't available.)
Oct 6, 2022  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, all good now then?
Oct 7, 2022  • #4
User Image
Mark S.
26 discussion posts
Hi,

Issue hasn't been solved yet. It does not show itself when the taskbars on the other monitors are triggered. This is desired. However, it still auto-hides while reserving screen area for where the taskbar should be. I want the taskbar to always display, and it doesn't seem to be doing that.

I'll upload some photos of the behavior.

Thanks!
• Attachment [protected]: reserved taskbar space.png [151,690 bytes]
• Attachment [protected]: taskbar options.png [253,591 bytes]
• Attachment [protected]: taskbar while not hiding.png [297,182 bytes]
Oct 7, 2022  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Oh, that's really strange! On the DisplayFusion Settings > Tasbkar tab, what's the Taskbar Opacity set to? If it's not already at 100%, can you set it to 100% and see if that helps?
Oct 7, 2022  • #6
User Image
Mark S.
26 discussion posts
Huh, the taskbar opacity was set to 1%. I don't recall ever changing that setting. Setting it to higher appears to make the taskbar appear all of the time. I just returned it to 100% and it looks like that made it show all the time. I guess a question I'd have would be: Why would that cause the particular behavior with the taskbar becoming opaque and showing like an auto-hidden taskbar when hovering over the very bottom edge of the screen?

In any case, changing the opacity fixes the issue. Thanks again!
Oct 7, 2022  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
That's how that feature is supposed to work, it makes it translucent when the mouse isn't over top of it. It's a super old feature from the very early days of DisplayFusion (Windows XP days!).
Oct 11, 2022  • #8
User Image
Mark S.
26 discussion posts
Ah! Thanks for letting me know. That's interesting. In any case, things are working well so far. Thanks again!
Oct 11, 2022  • #9
Was this helpful?  Login to Vote(1)  Login to Vote(-)