Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Taskbar Icon Stacking and button wack

Avatar from Gravatar.com
benway
342 discussion posts
Icon stacking and messed up buttons just started showing up today. (v3.0.4 beta).

It was just the icon stacking until I opened the settings dialog to get the version number. Then the buttons went wacky (see attached).

I usually push my system pretty heavily, and I am ready for a reboot, so no biggie.. just fyi...
• Attachment: DFbuttons.png [3,814 bytes]
DFbuttons.png
DFbuttons.png
May 14, 2009  • #1
John L. Galt's profile on WallpaperFusion.com
Ben,

what are your system specs? What are the current resource usage in terms of major apps and whatnot?

Just curious - it seems like it might be something more related to other parts of the XP desktop, in particular when the system is low on resources, or else when the system is resuming from a screen saver activation period / sleep / etc....

I know most of these ideas have been covered, but it is completely weird that this is happening mostly (if not always) on XP systems, where the desktop manager is not making use of the Graphics card like it should, whereas on Visa and 7 it is not, where systems 8are* making use of the Graphics cards independently of the CPU, for desktop rendering purposes....

Almost as if the code is being buggy *b/c* it prefers to work with the WDDM model as opposed ot hte DWM model found in XP....
I am I.
May 15, 2009  • #2
Avatar from Gravatar.com
benway
342 discussion posts
I have a high end DELL workstation (XP sp3), NVIDIA card (latest drivers) and 4 gigs ram. I use a lot of GUI intensive apps (camtasia, Cinema 4D, 3DVIA, PhotoShop, Illustrator, etc (frequently open at the same time)) (don't get me started on what HOG the CS4 suite is ) so I push the system pretty hard. It appears DF is the canary in the coal mine 'cuz it's the first to go south

A clue would be that first, it stops refreshing the button icons. Then, you can almost guarantee, when you open up the DF settings window the buttons themselves break to what seems to be generic XP buttons with no style applied to them at all.

I almost never see this bug anymore, so something's improving, but I think it's just better hidden, not fixed.

Anyway, as I say, it's rare now and I can live with it. I'd rather see Jon apply his efforts to the coming OS, not the fading one.
May 15, 2009  • #3
John L. Galt's profile on WallpaperFusion.com
Yeah, you're pushing them pretty hard....not sure if others are as much, though.

Although I *personally* would love to see more and more Win7 support, I don't want to leave the diehards out in the wind....
I am I.
May 15, 2009  • #4
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
I would be interested to hear if this issue occurs with any of the new 3.0.5 beta versions. I have completely changed the button/taskbar rendering process. It is more similar to version 3.0.1 now (which never had this issue). Thanks!
May 17, 2009  • #5
Avatar from Gravatar.com
benway
342 discussion posts
Quote:
I would be interested to hear if this issue occurs with any of the new 3.0.5 beta versions. I have completely changed the button/taskbar rendering process. It is more similar to version 3.0.1 now (which never had this issue). Thanks!

I'll run 3.0.5 at work where the problem cropped up and let you know... Thanks for all your work.. take a few days off!
May 18, 2009  • #6
Avatar from Gravatar.com
kruzayn
8 discussion posts
I just downloaded 3.0.5 this afternoon. My 2nd taskbar had gone brain dead (wrong labels and icons etc). What worked for me initially was to turn off 'Windows Uses Visual Styles' It was the ugly grey bar, but the content of the bar was correct; and I didnt have to reboot. I would turn visual styles back on and it was still brain dead. This was a good work around since it allowed me to still use the bar and finish the day of work before rebooting.

I downloaded 3.0.5 when still brain dead. Turned off DF and copied the files over and started it up again. Since when I quit Use Visual Styles was turned off. I turned Visual Styles back on and it had brains again . This usually only was fixed with a reboot so I have high hopes for the newest version here.

The first couple of days using the system without a real shutdown works well, its about day 4 that it goes brain dead. I go to Standby instead of turning off between home and work.
May 22, 2009  • #7
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
I hope that this issue has finally been resolved in the latest beta. Please give it a try and let me know if it happens again:
http://www.binaryfortress.com/Forum/index.php?topic=933.0

Thanks!
May 25, 2009  • #8
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply