Title

Message

Confirm

<< DiscussionsReply

The maximise view causes bottom of window to be hidden behind task bar

Avatar from Gravatar.com
GD800
4 discussion posts
Hi, when I have split screen activated on a widescreen, there is a problem when maximising windows to fill the whole "virtual monitor" space. On the left split it seems fine, but on the right the bottom of the window is hidden behind the task bar (this seems to happen regardless of whether I use the duplicated DisplayFusion task bar or turn that off so the native one spans the whole width of the real screen). It means that the bottom of the maximised window on the right cannot be seen or accessed (e.g. lower section of web pages, or the section with zoom slider and word count info etc in MS Word... and so on).
• Attachment [protected]: DisplayFusion task bar hiding botom of window.txt [211,595 bytes]
• Attachment [protected]: DisplayFusion task bar hiding bottom screenshot.docx [182,804 bytes]
Dec 21, 2020  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It looks like the bounds for the left split start at X=1 for some reason. Could you try changing the "Left" value for the left split from 1 to 0?
Dec 23, 2020  • #2
Avatar from Gravatar.com
GD800
4 discussion posts
Hi, many thanks for the suggestion. I'm not sure what you mean by bounds. I'm trying the location values in "splits and padding"- this was already set to 0 (for the top box, named "Left:") for the left split however. I have tried changing and then back to 0 again but the problem remains... is this is not the correct settings, please could you point me in the right direction for the correct settings, or if it is, any other suggestions?
Note also, the problem occurs on the bottom the the right split but is fine on the left.
Many thanks.
• Attachment [protected]: DF-TBprob.docx [96,439 bytes]
• Attachment [protected]: Splis.png [92,044 bytes]
Dec 23, 2020  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It looks like the X value is correct now, strange that the issue is still happening! If you do a full reboot now, does the issue still occur afterward?
Dec 24, 2020  • #4
Avatar from Gravatar.com
GD800
4 discussion posts
Hi, it's still the same after reboot unfortunately.
Dec 26, 2020  • #5
Avatar from Gravatar.com
Chris Salvian
15 discussion posts
I've got the same thing happening (though my taskbar is at the top) since I did a clean reinstall of my entire computer. I'm running 9.7.1 Beta 10.
• Attachment [protected]: Screenshot 2020-12-28 114150.png [208,631 bytes]
Dec 28, 2020  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Chris: Could you attach a copy of your DisplayFusion troubleshooting window as well so that I can compare?

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached

Thanks!
Dec 30, 2020  • #7
Avatar from Gravatar.com
Chris Salvian
15 discussion posts
Actually, I updated to 9.7.1. and the problem appears to have gone away. I'll keep you posted if it comes back.
Dec 30, 2020  • #8
Avatar from Gravatar.com
JoshQuest1
1 discussion post
For my googlers who are having this issue themselves.

I didn't want to be that person that found a solution and then didn't relay the information.

The solution I found was:

Step 1: Right click the displayfusion taskbar that your window is hiding behind.
Step 2: Navigate to "Multi-Monitor Taskbar"
Step 3: Navigate to "Position"
Step 4: Change from "Default" to <Your preferred orientation on the screen.>
In my case this was bottom.

The windows are no longer hiding behind the displayfusion taskbar, and you can maximize without them trying to hide.
Dec 30, 2020  • #9
Avatar from Gravatar.com
GD800
4 discussion posts
Thanks for the tip @Josh. Unfortunately that didn't solve the issue for me (it is only hiding behind the main original task bar in split 1 however, not the DF one on the 2nd split for some reason). I've just had an update notification so going to try that and see if it resolves like @Chris' did.
Failing that, I have managed a work around using the padding settings by adding a 30 pixel pad (out of 1080) to the bottom padding setting (this seems OK so far for my general Office progs etc)... will update if I notice any issues on other things from doing this.
Dec 30, 2020 (modified Dec 30, 2020)  • #10
Avatar from Gravatar.com
MarkCross
1 discussion post
@JoshQuest1

I'm one of the googlers you were speaking about. The problem was driving me crazy, your solution worked for me. Thanks a lot!
Jan 14, 2021  • #11
Avatar from Gravatar.com
sh0sh1n
4 discussion posts
Quote:
For my googlers who are having this issue themselves....

The windows are no longer hiding behind the displayfusion taskbar, and you can maximize without them trying to hide.


This also fixed my issue as well, mine was set to automatic and I changed it to "Bottom"

Note for others reading this that this is referring to the position of the Task Bar, not the window, so choose whatever edge of the screen you're used to having your task bar appear on!
Jan 14, 2021  • #12
Avatar from Gravatar.com
Kevin Morrison
12 discussion posts
Quote:
For my googlers who are having this issue themselves.

I didn't want to be that person that found a solution and then didn't relay the information.

The solution I found was:

Step 1: Right click the displayfusion taskbar that your window is hiding behind.
Step 2: Navigate to "Multi-Monitor Taskbar"
Step 3: Navigate to "Position"
Step 4: Change from "Default" to <Your preferred orientation on the screen.>
In my case this was bottom.

The windows are no longer hiding behind the displayfusion taskbar, and you can maximize without them trying to hide.


Thanks buddy, this is exactly the solution I was looking for. Thanks a ton for taking the time to help us out!
Jan 14, 2021  • #13
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

This issue should be fixed up in the latest beta, available here: https://www.displayfusion.com/Download/Beta. Please let me know if you still run into any trouble after updating.

Thanks!
Jan 15, 2021  • #14
Avatar from Gravatar.com
Ignotus
9 discussion posts
JoshQuest1's solution does indeed help somewhat with my issue. My Edge browser window was behind the DisplayFusion taskbar, which has been very annoying. That seems to be fixed by choosing BOTTOM instead of AUTO for the location. However, I'm still experiencing a very annoying issue that I thought was supposed to be fixed by 9.7.1. I'm using the Steam version, and full-screen YouTube videos playing in Edge still appear behind the DisplayFusion taskbar. It's makes it impossible to access the video controls. I've set Edge to be treated as a full-screen app in compatibility settings, and I've verified that "show taskbar in front of full screen applications when they lose focus" is still unchecked. Is there still no solution for this?
Jan 16, 2021  • #15
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Can you try updating to our latest beta and see if the issue persists? You can do so by opening up the Display Fusion settings window, heading to the Options tab, enabling "Check for new beta versions" and then clicking "Check for updates now".

Thanks!
Jan 18, 2021  • #16
Avatar from Gravatar.com
Kevin Morrison
12 discussion posts
As I had stated the instructions from JoshQuest1 worked for me. however then along came an NVIDIA driver update and I was right back to having the issue again. I installed the beta and it fixed the issue again. Now the only question is if it resolves it or not. Hopefully knowing about the video card driver update causing it helps to resolve this problem if it does not.
Jan 18, 2021  • #17
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Kevin,

Interesting, thanks for the note! We made some adjustments to our taskbar reloading timer, so it shouldn't be dependent on your drivers, but if it does come back just let us know.

Thanks!
Jan 18, 2021  • #18
Avatar from Gravatar.com
Ignotus
9 discussion posts
Updated to 9.7.2 beta 3 (Steam) and issue persists. My Nvidia driver is 461.09 1/7/2021. I'll attach a screenshot showing the YouTube controls behind the taskbar in full screen view.
• Attachment: taskbar youtube.png [14,937 bytes]
taskbar youtube.png
taskbar youtube.png
Jan 19, 2021  • #19
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Is this happening with any other web browsers, or just edge?

Thanks!
Jan 19, 2021  • #20
Avatar from Gravatar.com
Kevin Morrison
12 discussion posts
I am using Chrome, Firefox and Opera and it is happening on ALL of them. I rarely ever even open Edge but its happening on that one too. I honestly dont think this is a browser issue, I think its something closer to the OS and drivers than that.

Just to test this I downloaded the latest NVIDIA drivers and reinstalled them and using the Beta of Display Fusion it did not come back and hide the browser. Of course I only reinstalled over the same driver but if I get time I will roll back the drivers and go through the normal update process and see if it does it again.
Jan 19, 2021 (modified Jan 19, 2021)  • #21
Avatar from Gravatar.com
sh0sh1n
4 discussion posts
Sorry if this is off topic but how do I unsubscribe from a thread's updates? Theres no unsub button in the emails and in my "Discsussions" tab from the menu there isn't any way to remove them from that list
Jan 19, 2021  • #22
Avatar from Gravatar.com
Kevin Morrison
12 discussion posts
You know what this reminds me of, if you take your focus off of a window that is in full screen, the task bar always stands out in front. Perhaps that has something to do with why this is happening? Maybe the software is not seeing that the browser window is in fact the live window, or is not being reported to Display Fusion that it is the live, active window? Hope that gives you more to go on.
Jan 19, 2021  • #23
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

@sh0sh1n You can head to your account info and uncheck "Allow Discussion Emails"

@KevinMorrison Are you experiencing this only when full screen in these browsers? If you open up the Display Fusion settings window and head to the Taskbar tab, is "Show taskbar in front of full screen applications when they lose focus" unchecked?

Thanks!
Jan 20, 2021  • #24
Avatar from Gravatar.com
Kevin Morrison
12 discussion posts
@Owen Muhlethaler - No I am saying this issue acts like it does if you are in full screen mode in the browser and then say click something else on a different monitor. So say you are viewing a video in full screen mode and you click a folder or anything on a different monitor, the task bar is visible above the video and you cant get to the scrubber on the video or icon to reduce the full screen unless you either click the video, or click the browser icon in the taskbar to make it active again. So what I am saying is this problem we are having acts like what I described, even if you have focus (active) on the browser, it is still hiding behind the taskbar.
Jan 20, 2021  • #25
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Kevin,

Interesting, could you confirm for me that you have "Show taskbar in front of full screen applications when they lose focus" unchecked?

Could you also send me a copy of your troubleshooting info while the taskbar is sitting on top of one of your applications? Here are the steps:

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached

Thanks!
Jan 20, 2021  • #26
Avatar from Gravatar.com
Ignotus
9 discussion posts
I lost track of the discussion due to being busy with work. In my scenario, I do not have the browser full screened (F11). I'm using the full screen option that's in the YouTube interface to full screen the video player. However, I just tried full screening the browser with F11 and get the same result; the taskbar is in front of the browser window. For me, it doesn't matter if the window has focus or not. Full screening either the video or the browser works as expected on my primary monitor that's using the Microsoft taskbar. The issue occurs on the secondary monitor using the DisplayFusion taskbar. Can also confirm that "Show taskbar in front of full screen applications when they lose focus" has always been unchecked.

Attaching debug info.
• Attachment [protected]: DisplayFusionDebugInfo.zip [32,184 bytes]
21 days ago  • #27
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Thanks for sending that over. If you head into your advanced setting in Display Fusion, can you disable the "Ignore Full Screen Windows" settings, and see if the issue persists?

Thanks!
18 days ago  • #28
Avatar from Gravatar.com
CharlieC
1 discussion post
I have the same issue.

For now I'm doing a workaround.

Close DisplayFusion,
Set the taskbar controlled by Windows to autohide in desktop mode,
Run DisplayFusion

So at least the window maximizes and I can see the bottom of the window.

I would prefer to see my taskbar with a maximized window, so let me know if you figure something out.
15 days ago (modified 15 days ago)  • #29
Avatar from Gravatar.com
Ignotus
9 discussion posts
Quote:
Hello,

Thanks for sending that over. If you head into your advanced setting in Display Fusion, can you disable the "Ignore Full Screen Windows" settings, and see if the issue persists?

Thanks!

🤦‍♂️
Oh man, when I saw this reply, I first lol'd and then thought "please don't let that be the solution". Well, for me at least, that seems to have solved it, and I feel like a total jackass. I guess the logs performed their function though. I don't remember why I set that option. It was probably a long time ago for some trigger that had something to do with a game.
15 days ago  • #30
Avatar from Gravatar.com
Ignotus
9 discussion posts
EDIT: Restarted Explorer.exe and it seems OK now. 🤷‍♂️
Now there's a weird situation where the taskbar flickers and the start button flickers between grey and white. Also, the DisplayFusion start menu doesn't work. I've only noticed it when I have Edge not minimized. If I minimize Edge, the taskbar looks fine and works. If I use Chrome, the taskbar behaves normally as well. For some reason, it looks like the task bar is crashing and reloading when I have Edge visible. Oh, quite a bit of delay when pressing the start button as well.
EDIT: I should add that I did something a while back to turn my Microsoft task bar more transparent. It may have been a registry mod, I don't remember. I believe it was this: https://www.howtogeek.com/258681/how-to-make-the-windows-10-taskbar-more-transparent/
• Attachment: 2021-02-20 15_23_08-.png [34,933 bytes]
2021-02-20 15_23_08-.png
2021-02-20 15_23_08-.png
14 days ago (modified 14 days ago)  • #31
Avatar from Gravatar.com
Ignotus
9 discussion posts
Recap: The taskbar flickering persists along with the DisplayFusion start menu button being mostly grey and flickering white occasionally. The start menu doesn't work when the button is grey. I only notice this when Edge is visible. I don't have Edge in F11 full screen mode. If I minimize Edge or use Chrome, the start menu button is white and works fine. I have a non Steam version of DF at work where I also use Edge, and I haven't noticed this issue there. I'll have to look to see if the "ignore full screen windows" advanced setting is enabled at work. If I reenable that setting at home, it seems to fix the taskbar flickering issue. I'll attach some images and another debug zip while the start menu is grey/non working and the advanced setting (ignore full screen windows) disabled.
• Attachment [protected]: DisplayFusionDebugInfo.zip [33,950 bytes]
• Attachment: flickering.png [48,383 bytes]
flickering.png
flickering.png
14 days ago (modified 14 days ago)  • #32
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

If you disable your compatibility setting that forces Edge to be treated as full screen, does the issue persist?

Thanks!
9 days ago  • #33
Avatar from Gravatar.com
Ignotus
9 discussion posts
The issue does NOT persist lmao. Apparently I've ended up with some odd and conflicting settings over the years and forgot about them. So I was likely having the issue with full screen YouTube videos being overlapped by the taskbar in Edge due to having the advanced setting "ignore full screen windows". I have no idea why I turned that on. Then I probably went and changed the compatibility setting to force Edge to be detected as full screen in an attempt to overcome the advanced setting I had forgotten about. 🤦‍♂️ If I turn off the advanced setting and remove the compatibility setting for Edge, it all seems to work as intended. You deserve a beer.
6 days ago (modified 6 days ago)  • #34
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hello,

Glad to hear we got it sorted out! If you have any other questions, feel free to reach out to us.

Thanks!
5 days ago  • #35
Was this helpful?  (1)  
<< DiscussionsReply