Title

Message

Confirm

VS Code not maximizing to split borders

Hans Andersson29906
7 discussion posts
Hi,
I've recently installed Displayfusion on my work laptop.
Everything works fine except one thing. MS VSCode doesn't work with the monitor setup. It only knows about Windows Monitor borders (i.e. it doesn't maximize to my split borders).
I have the latest version of VS Code and Displayfusion.
Any ideas on where to start looking?
Best regards,
Hans
Nov 2, 2021  • #1
Hans Andersson29906
7 discussion posts
For some reason it just started working.
Have no idea what happened. I tried multiple things over the last couple of days and now it just decided to start working.
Sorry for not knowing what caused it for readers finding this thread in the future.
Nov 2, 2021  • #2
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Hans,

Strange, if the issue comes back just let us know.

Thanks!
Nov 2, 2021  • #3
Hans Andersson29906
7 discussion posts
That was really temporary.
It only worked that day and then it stopped working again.

Any suggestions on where to start troubleshooting?
Nov 15, 2021  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Next time it's not working, could you grab a copy of the troubleshooting info for us? Here are the steps:

  • Open the Settings > Troubleshooting tab
  • Click the "Export Info to File" button
  • Reply with the file attached

Thanks!
Nov 15, 2021  • #5
Hans Andersson29906
7 discussion posts
Here it is. I was working with another screen setup yesterday on which I don't use DisplayFusion.

I'm experiencing the issue right now so the troubleshooting info was taken while I have the problem.

Thanks in advance!
• Attachment [protected]: DisplayFusionDebugInfo.zip [57,644 bytes]
Nov 17, 2021  • #6
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Hans,

Thanks for sending that over. When the issue happens, do any other windows have issues besides VS code?

Thanks!
Nov 17, 2021  • #7
Hans Andersson29906
7 discussion posts
It's only VS Code that I noticed anyway.
Other software like Firefox, Chrome, Edge, Outlook, Spotify, Slack and others work just fine.
Nov 18, 2021  • #8
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Hans,

Okay interesting, I was testing it on my end but I couldn't seem to reproduce it. When you maximize it to a split, are you clicking the maximize button, double clicking the titlebar, or dragging it into a split to have it snap to the correct size?

Thanks!
Nov 18, 2021  • #9
Hans Andersson29906
7 discussion posts
I think I found the problem.

My VS code is started as an administrator due to policies and since I didn't start it as an administrator I never made the connection. But now I see the [Administrator] in the titlebar.

I tried running notepad in my regular runspace and then everything works as expected and when I start notepad as an administrator it to doesn't care about Displayfusions settings.

So I will call this closed from my point of view unless there is a way of get application that run the in the administrator runspace working. Is there?
Nov 19, 2021  • #10
Hans Andersson29906
7 discussion posts
Turns out that it's my way of automatically starting Displayfusion that's causing it. Need figure out a better way since the default way is blocked by policies =(
Nov 19, 2021  • #11
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Hans,

Ah, if that application is running elevated and DisplayFusion isn't, it may not be able to hook it into the splits. Are you able to run DisplayFusion manually as administrator to see if that fixes it up?

Thanks!
Nov 19, 2021  • #12
Was this helpful?  (-)  (-)