Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Wallpapers on rotate makes desktop icons scroll off screen...

User Image
kludeman
6 discussion posts
Ok, I'm not sure I've completely nailed this one down, but this is my setup and the behavior I am seeing:

I have my primary display (laptop 1600x900) and an external on the left (1920x1200). The bottom of the external is about 3 inches above the bottom of the laptop screen, and the laptop screen top is about halfway up the height of the external. Windows (Win7x64) is configured with them positioned this way.

The behavior that I am seeing is that when I move the mouse up against the top of the primary desktop, all of the icons on the desktop slide down the screen, and then when I move the mouse back against the bottom of the screen, they slide back the other way. Like having a 1600x900 viewport over a larger resolution, but the amount of "scroll space" is dependent on how high the external monitor is. If I move the position of the external in windows so that the tops are even, then my primary screen only scrolls downward not upwards.

ok, so now to where I think DisplayFusion comes in...if I set a single background image to both monitors (i.e. not rotating) and then log off and back on, everything is fine. If I set the screens to rotate, and then log off and back on, everything is fine until the first image rotation, after which I get the behavior described above. Same thing happens if I use the "Load Next Image" for the first rotation before the timer. Same thing happens if I use a hotkey combo to tell it to rotate to the next image.

Honestly, this could totally be an nVidia driver thing that is causing this, but Ive looked through all the settings there and haven't found anything relevant. Oh and its only the icons that scroll up and down...other windows stay put whey are.

Is there any way to download an older version? I'd like to try and see if that makes a difference - I can't for sure say at what point it started, but Ive been using DF for a year and a half over numerous releases and betas and pretty sure I just noticed this happening in the past few weeks.

Any thoughts?

Keith
Sep 28, 2010  • #1
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Are you using Windows 7? If so, you can revert to the "old" style of wallpaper changes by unchecking the "Use wallpaper transitions" option. Give this a try to start, and let me know if this doesn't help. :)
Oct 1, 2010  • #2
User Image
kludeman
6 discussion posts
That did help...turning off the Win7 transitions stopped the weird scrolling.

I did find what I believe to be the primary cause - there is a checkbox on the display settings under On Screen Display called "Enable Auto Scroll Function". I believe this is part of the OSD & hotkey driver for my ThinkPad W510. Disabling this fixes the problem as well and I am back to the nice, pretty win7 transitions.

Thanks for the help,

Keith
Oct 4, 2010  • #3
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
That's an excellent discovery, thanks for following-up. :)
Oct 6, 2010  • #4
Was this helpful?  Login to Vote(-)  Login to Vote(-)