Title

Message

Confirm

<< DiscussionsReply

Watching iTunes movies maximized

Avatar from Gravatar.com
Ringgit
11 discussion posts
I have an ultra wide and DisplayFusion split it into 3 monitors, one padded. When I played iTunes movies, I usually press Shift and Maximize so that the iTunes movie window will maximized across all 3 virtual monitors. After a few seconds of playing, the window auto adjusted. It doesn't go edge to edge. It's a size of 90% of the actual physical monitor (and it is not the padded side). It seems DF is not allowing video to be played in Maximize mode.

If I click full screen at the bottom right of iTunes window, the video become full screen (such that it also hides the task bar.. video played full screen. That's nice, but my second physical monitor became blank! (this does not happen when I played video games full screen). Edit: this seems to be an iTunes issue https://www.reddit.com/r/osx/comments/17a3bm/how_has_apple_still_not_fixed_the_full_screen/

If I quit DF, I can play the iTunes movie maximized (+task bar) and it does not auto adjust.

What can I do (using DF 9.6 Steam version)? Ideally I would like to play iTunes video in maximized (and have the task bar too), not full screen.
Dec 21, 2019 (modified Dec 21, 2019)  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
On the DisplayFusion Settings > Compatibility tab, could you try adding a rule for iTunes, and in the rule, enable the "Force DisplayFusion to treat this application as full screen" option, and let me know if that makes any difference?
Dec 21, 2019  • #2
Avatar from Gravatar.com
Ringgit
11 discussion posts
Hi there and thanks for the tip. I put in two apps: iTunes and iTunes Helper into the Compatibility. The "Force DisplayFusion to treat this application as full screen" didn't fix it but I also checked the "Disable TitleBar Buttons (this application only) and that solved my issue. Now I can play my movies at maximized window! /fist pumping in the air!
Dec 22, 2019  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Excellent, glad to hear that worked!
Dec 30, 2019  • #4
Was this helpful?  Login to Vote(1)  Login to Vote
<< DiscussionsReply