Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Windows 10 - Dual Monitors - Window Snapping Issue: Snags on monitor at low speed

Avatar from Gravatar.com
Greg Simon
1 discussion post
I often drag a window from one monitor (A) to the other monitor (B). If I try to do this at a reasonable speed, the windows snags on the edge of the monitor (A) and can't be dragged to the other monitor. You essentially have to drag the window really quickly for it not to snag, and more often than not it snags because I'm not moving the window quick enough.

I have to tried disabling snapping altogether on Windows, because DisplayFusion has a Window Snapping feature, but when I disable it on Windows it appears to also disable the same functionality DisplayFusion uses. With the exception of the "Enable maximized window dragging between monitors" which does still work when then Windows 10 snap is disabled, thankfully.

It's a Windows 10 issue clearly, although I was hoping there might be a fix? either by editing the registry or a way to override Window's 10 snapping with DisplayFusion's?

Many thanks
Jul 31, 2015  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I'm assuming you disabled the Aero Snap stuff in the Control Panel > Ease of Access Centre? That definitely seems to be what's causing this, but disabling it shouldn't affect DisplayFusion's Window Snapping. You should still be able to drag a window near the edge of a monitor or other window to have it jump into alignment when Window Snapping is enabled in DF.
Aug 5, 2015  • #2
Avatar from Gravatar.com
Missiles
1 discussion post
Hey i'm a little late here, but i'm having a similar (possibly the same) problem...

Since i installed windows 10, whenever i drag a window from monitor to monitor it snags on the edge of the screen. I disabled the option from the ease of access settings and it no longer snags, but now instead when i try, my screen darkens and i see the huge '1' and '2' at the centre of my monitors.

I'm pretty bad at trying to explain what i mean...But before on windows 7: When i dragged a window it would become smaller/un-maximized, i could lay the window in the middle, spanning across both monitors if i wished, and dragging the window to the top of my screen would re-maximize it.
This is no longer the case, it's just like 'hey here's a full screen, where dya want it ?.. 1 or 2'

Hopefully a solution turns up eventually :D I had no idea how much i relied on this until recently.
Aug 19, 2015 (modified Aug 19, 2015)  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Missiles: On the Settings > Window Management tab, just disable the "Enable maximized window dragging" option, and that should fix up that issue
Aug 20, 2015  • #4
Avatar from Gravatar.com
lcs
1 discussion post
I had same issue like the other guys but the following config made it work magically.
For Win 10 config you need to change this (you can open it by typing "Multitasking" in your search bar )
Notice only first option is enabled resti is OFF


After that in settings of DisplayFusion you Disable(un-check) the "Enable Windows Edge Snipping to edges of Monitors"


if you notice I use the other "pro only" features of snaping to Applications because I love it..
• Attachment: FusionSnipping.JPG [56,143 bytes]
FusionSnipping.JPG
FusionSnipping.JPG
• Attachment: WinSetting.JPG [53,849 bytes]
WinSetting.JPG
WinSetting.JPG
Dec 27, 2015 (modified Dec 27, 2015)  • #5
Avatar from Gravatar.com
Andrew Reseigh82914
1 discussion post
Hi Keith,

You mention type multitasking on the start search, but it finds nothing and I have gone through the control panel in Win10 and can't find the settings you are talking about.

Do I need to switch something else on to allow these config windows.
Jun 30, 2016  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Should be in the Windows 10 "Settings" app, not the Control Panel. In the Settings app, go to System > Multitasking
Jun 30, 2016  • #7
Avatar from Gravatar.com
mryan21
1 discussion post
If you don't want to drag, you can hold SHIFT + Windows Key + Left/Right arrow...that'll move the active screen from monitor to monitor.
Aug 10, 2016  • #8
Avatar from Gravatar.com
Michael Klinteberg53745
1 discussion post
I found two options to solve the issue.
a) Move the window faster and it will not snap to the edge.
b) Use keyboard shortcut <Winkey>+<arrow key> (example Win+Left)
Oct 26, 2016  • #9
Avatar from Gravatar.com
Eric Roberts82564
1 discussion post
I had to disable the first option as well in the Windows 10 Multitasking configuration. This must be the result of the latest update...they did do some major changes apparently. I never had a problem with this until after the update. I don't think I was moving windows from monitor to monitor any slower than normal. YEs, you can drag them real fast across the edge of the monitor to get it across with this feature in place, but the only way to allow you to do this at any speed was to disable all 4 Snap config options.

Eric
Oct 28, 2016  • #10
Avatar from Gravatar.com
StuartM 70503
1 discussion post
I have had the same problem for several months after I added a second monitor. The work around was indeed to move the window very fast from one screen to another, and I have used that for a few months, but it seemed ridiculously fast to get it to work.
At work I use Win10 with dual monitors and they work perfectly without the need for super fast movement between screens.
After comparing the two I worked out that the fast movement required to move the window to the second screen was due to the mouse I was using.
I normally use a high DPI gaming mouse (set fairly low), if I use this whenever I move the window between screens it tries to snap unless I move it very quickly.
Using a cheap $10 mouse the problem goes away. It works perfectly. I can plug both mice in at the same time and the cheap one works perfectly while the expensive one causes the snapping issue.

For me the workaround is to move the window very fast.
The cause is the high quality high DPI mouse I use.
MS should fix this.
Dec 8, 2016  • #11
Avatar from Gravatar.com
Liquidape
1 discussion post
StuartM Led me to do some tests - I asked myself about how a cheap mouse is different than an expensive one. One major change is the polling rate of the mouse. I have a razer naga hex V2 mouse that can dynamically change the polling rate. So I decided to test that with the window snapping. Sure enough, If I set the polling rate really low (125) the issue goes away. At 500, the issue is there, but manageable - you still have to move the windows pretty fast between monitors, but not ludicrous speed. At 1000 the issue is very bad and you basically have to move the mouse as fast as you can between windows or snapping will stick it to the original window. Hopefully somebody @ microsoft reads this and fixes the issue.
Dec 28, 2016  • #12
Avatar from Gravatar.com
AlsoKnownAsJazz
1 discussion post
I've spent a ton of time wrestling with this issue, and I don't think it's related to Windows Snap features. It's possible to have your monitors aligned in display settings where they APPEAR to be perfectly adjacent, but actually aren't - there's a pixel or two of dead space between them. You can use the arrow keeps to move the monitors around (in the display settings screen) which sometimes helps. I just discovered that if you hold shift when pressing the arrow keys, it seems to move the monitors in very small (single pixel?) increments, which finally did the trick.

Also, when using the arrow keys to relocate your monitors, one monitor can 'push' another monitor, but it can't push two, so if you have three monitors in a horizontal row, you should try pushing the outside monitors towards the center one.

Attached is an image with examples. Top is my setup, 2nd one is after I moved monitor 1 with Shift + Right Arrow, and bottom is after I moved monitor 1 with Right Arrow (no shift).

Hope it helps!
• Attachment [protected]: MonitorLayout.jpg [48,975 bytes]
Aug 10, 2017  • #13
Avatar from Gravatar.com
RayK1
1 discussion post
APPLICATION OPEN IN FULL SCREEN COULD NOT BE DRAGGED TO ANOTHER MONITOR
I know this thread is old but this was a recent problem for me. I also spent excess time on this annoying problem, a lot of different attempts at settings. Not being able to drag aopen application when it was full size was such a time waster. This "feature" started a couple of months ago after a "dreaded" win 10 update. lcs's solution posted above "magically" worked for me.
To get to those settings I used left-click to access display settings, then multitaking...
Apr 11, 2019 (modified Apr 11, 2019)  • #14
Avatar from Gravatar.com
Jordon Gonzales63644
1 discussion post
Making a simple post for any others coming across this after google searches on the same issue such as I.

While not a DisplayFusion user, the resolution is to move the window at high velocity between monitors. A quick flick of the wrist while dragging will surpass edge snapping. I can't speak for users with DisplayFusion. I do suggest never having drinks near by :-[

If you don't ever use the snapping technology, then turn off window snapping under multitasking.
Jun 7, 2019  • #15
Avatar from Gravatar.com
TE5LA
1 discussion post
This has been a pain for me in the past. Windows always stopped at the edge and I have to smack the window against the edge of the monitor as if there is some physical barrier there. Idiotic, but I found the fix (Windows 10):

Open "Control Panel", not the one from the gear icon under START, but type it into the search bar. It's different from the other. It's more like the old school Windows XP Control Panel.

Click the main "Ease of Access" link.

Under "Ease of Access Center", select "Change how your mouse works". Yeah, it seems odd for something more related to the display, but this is it.

Look for a tick box with the line "Prevent windows from being automatically arranged when moved to the edge of the screen" and check it.

Press OK, you're done!
17 days ago  • #16
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply