Title

Message

Confirm

<< DiscussionsReply

Windows 10 - small taskbar Systray clock text is too large with large DPI

erbkaiser's profile on WallpaperFusion.com
I'm using my work laptop with large scaling/DPI (150%) on the native screen, and two attached monitors with normal scaling. All screens are running the native 1080p resolution and I am using DisplayFusion to give each screen its own taskbar.
Under this setup, the system tray clock on DF taskbars is far too large. I have narrowed it down to the DPI setting: if I set this to 100% for my laptop screen, the DF taskbar clocks display correctly.
Things I've already tried which did not help:
-Setting a custom size for the DF taskbar (30px to match Windows small taskbar)
-Advanced Setting - Font Scaling: Force X/Y
Is there something else I can try, or is this a known issue with scaling?
• Attachment: df-taskbar.PNG [7,515 bytes]
df-taskbar.PNG
df-taskbar.PNG
• Attachment: win-taskbar.PNG [8,935 bytes]
win-taskbar.PNG
win-taskbar.PNG
Mar 14, 2019  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
This usually happens if the scaling level in Windows has changed but the system hasn't been logged out/logged in. The next time you run into this, could you try a logout/login?
Mar 14, 2019  • #2
erbkaiser's profile on WallpaperFusion.com
Thanks, that fixed the issue.
It means I need to make sure to have the additional screens attached before I power on the laptop, but that's something I can get used to.
Mar 15, 2019  • #3
Nathan McGuire24684
4 discussion posts
I'm hoping this can be fixed. I have the large time/date issue as well. I have a surface pro and dock and undock with different configurations, so I don't want to have to log out and lose my work when I go from one location to another.
Aug 13, 2019  • #4
Nathan McGuire24684
4 discussion posts
I'm just wondering is there is any update on fixing this issue? Sorry but it is the one annoying thing about DisplayFusion.
Jul 20, 2020  • #5
Nathan McGuire24684
4 discussion posts
Quote:
This usually happens if the scaling level in Windows has changed but the system hasn't been logged out/logged in. The next time you run into this, could you try a logout/login?

Hey Keith, just thought I'd quote you to see if there's any update on this issue?
Jul 20, 2020  • #6
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Sorry Nathan, unfortunately this is a Windows issue and requires a logout/login to fix.
Jul 20, 2020  • #7
rondodev
1 discussion post
incorrect post removed
Dec 10, 2020 (modified Dec 10, 2020)  • #8
Safwat Gabr
2 discussion posts
Every time I start my computer the clock font size issue appears. I have to log off and in again after every restart for this to get fixed, which is still annoying. There must be a way to refresh it at every start, not just at logging in!
Apr 25, 2021  • #9
Kevin Kuhle
6 discussion posts
Most of the apps I run into text size issues because of display scaling, I can restart the apps and it is back to normal. DisplayFusion does not get fixed if I kill every related process that I find and restart the app. Is there anything else that can be done to have DisplayFusion fix the font size after restarting the app?
Messing with the Compatibility settings maybe is allowing this to work better for restarting the application.
1. Navigate to C:\Program Files (x86)\DisplayFusion
2. Right-click DisplayFusion.exe > Properties > Compatibility tab > click Change high DPI settings
3. Set "Use the DPI that's set for my main display when" to "I open this program"
4. Check "Override high DPI scaling behavior.
5. Select the dropdown for "Scaling performed by:" to "System" and click OK
6. Restart DisplayFusion
I haven't tested it further than changing these settings, restarting DisplayFusion and getting a normal font size for the clock for the taskbar while I'm still logged in and connected to my dock with my other monitors where my display scaling is back to 100% on all monitors. I suppose this may not work for everyone depending on their scaling settings.
May 19, 2021 (modified May 19, 2021)  • #10
Nathan McGuire24684
4 discussion posts
Not sure if this helps, but I finally turned the clock display off on the taskbars that weren't displaying correctly. While I wish it worked, it isn't as annoying or distracting as seeing the wrong size text.
I also had a similar issue with an Outlook plugin but I figured out how to turn on compatibility mode and that fixed it.
May 19, 2021  • #11
Safwat Gabr
2 discussion posts
I got this fixed by setting a default font size to it rather than making it scale on its own. Thank you for the proposed solutions I will test them as well.
May 19, 2021  • #12
LaughDonor
1 discussion post
Quote:
1. Navigate to C:\Program Files (x86)\DisplayFusion
2. Right-click DisplayFusion.exe > Properties > Compatibility tab > click Change high DPI settings
3. Set "Use the DPI that's set for my main display when" to "I open this program"
4. Check "Override high DPI scaling behavior.
5. Select the dropdown for "Scaling performed by:" to "System" and click OK
6. Restart DisplayFusion

Thanks Kevin! This worked out great!
May 24, 2021  • #13
Kevin Kuhle
6 discussion posts
That's good to hear! I've not noticed any issues over the last few days switching from undocked (laptop only) to using by dock with changing DPI settings, so I'm crossing my fingers this will continue to be an effective workaround for my usage.
May 25, 2021  • #14
Was this helpful?  (3)  (1)
<< DiscussionsReply