Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Windows key opens the start menu on the wrong monitor

Avatar from Gravatar.com
carolares
2 discussion posts
Hi there,

I've seen another old post on this discussion but didn't know if it's ok to resurrect that ancient thread. That's been said, I'm running windows 10 at the moment and this issue never occurred back when I was using win7 on this machine.

steps:
(dual monitor setup)
- move cursor on the monitor on the left
- hit windows key (everything's ok)
- move cursor on the monitor on the right
- hit windows key again (everything's ok)
- move the cursor on the previous monitor and hit windows key

notice: even though the cursor is on the monitor on the left, the start menu is opening on the monitor on the right and never switches back - start menu constantly opens on the monitor on the right now.

workaround to make the start menu to open back on the monitor on the left is to open the start menu WITH THE MOUSE CLICK on the monitor on the right, then when I switch back to the monitor on the left, hitting the windows key will open the start menu on the correct monitor.

I also attached the troubleshooting log to provide potentially useful information.
• Attachment [protected]: troubleshooting log.txt [159,818 bytes]
Jan 18, 2017  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I can reproduce this if I repeatedly press the Win key, but if I wait a few seconds between your steps 4 and 5, it moves back correctly. Does it make any difference for you if you wait longer?
Jan 19, 2017  • #2
Avatar from Gravatar.com
carolares
2 discussion posts
Hello again,

Yes, if I wait around ~5s it seems that the start menu will be opened on the correct monitor.
Jan 19, 2017  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, that's more or less expected. Because we can't hook the Start menu, we have to poll and wait for a timeout period before moving it back to the Primary monitor.
Jan 20, 2017  • #4
Avatar from Gravatar.com
LupusRex
2 discussion posts
Is it possible to make the start menu open in a fixed designated monitor? i.e always open start menu in monitor 1 even though mouse position is on monitor 2?
Jan 15, 2018  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
There is an Advanced Setting that's supposed to do this, but it looks like it's broken in Windows 10

I've added it to our list to fix up.

Thanks!
Jan 16, 2018  • #6
Avatar from Gravatar.com
LupusRex
2 discussion posts
There is an advanced options?
Jan 17, 2018  • #7
Avatar from Gravatar.com
Scott Brown
2 discussion posts
Where is this advanced option and has it been updated?
Aug 28, 2018  • #8
Alan Wade's profile on WallpaperFusion.com
Quote:
There is an advanced options?
Where is this advanced option?


Right click on a DisplayFusion taskbar and select Options. In the box that opens look down at the bottom and you will see a link called Advanced Options - click that.
Aug 28, 2018 (modified Aug 28, 2018)  • #9
Avatar from Gravatar.com
Scott Brown
2 discussion posts
Quote:
Quote:
There is an advanced options?
Where is this advanced option?


Right click on a DisplayFusion taskbar and select Options. In the box that opens look down at the bottom and you will see a link called Advanced Options - click that.


Thank you. Where can I find this option to disable Windows key on other monitors.
Aug 28, 2018  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It's the advanced setting called "Taskbar: Windows Key Opens Secondary Start Menu" but note that it's currently broken in Windows 10. This was a really old setting from when we first added multi-monitor taskbars in the Windows 7 days. I'll post an update here when we've fixed it up for Windows 10.
Aug 28, 2018  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Note that you can disable the Start menu from opening on the second monitor by right-clicking the DisplayFusion taskbar and navigating to Multi-Monitor Taskbar > Start Button > Disabled. But of course, that will also remove the ability to open the Start button with the mouse on the second monitor.
Aug 28, 2018  • #12
Avatar from Gravatar.com
Josh Peterson31319
1 discussion post
Hi,
Sorry to reply on this oldish thread, but I'm experiencing a similar issue...
The start menu opens on the correct screen, but when i begin typing to search it moves back to the primary monitor. I'm on Win 10 with DF 9.5... Thank you
Oct 25, 2019  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Josh: That's unfortunately expected. We're able to poll and move the Start menu, but the Search menu forces itself back to the primary monitor
Oct 25, 2019  • #14
Avatar from Gravatar.com
phishingNetz
2 discussion posts
Quote:
It's the advanced setting called "Taskbar: Windows Key Opens Secondary Start Menu" but note that it's currently broken in Windows 10. This was a really old setting from when we first added multi-monitor taskbars in the Windows 7 days. I'll post an update here when we've fixed it up for Windows 10.


Been a couple of years, is it going to get fixed any time soon?
3 days ago (modified 3 days ago)  • #15
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@phishingNetz: Can you clarify the issue you're running into?

Thanks!
2 days ago  • #16
Avatar from Gravatar.com
phishingNetz
2 discussion posts
Quote:
@phishingNetz: Can you clarify the issue you're running into?

Thanks!


The secondary start menu will still open on the secondary monitor, even when disabling it from the advanced option "Taskbar: Windows Key Opens Secondary Start Menu". This thread was describing how this option was broken for some time and it still seems to be.
2 days ago  • #17
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, thanks! That issue is still open on our list, if it's an easy fix we'll try and fit it in for 9.7.

In the meantime, if you don't want to use the Start menu at all, you can right-click in a blank spot on the DisplayFusion taskbar and choose Multi-Monitor Taskbar > Start Button > Disabled.

Thanks!
2 days ago  • #18
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply