Title

Message

Confirm

10.0b16 Process Created/Ended trigger not working properly

Hollo
73 discussion posts
Hi,

In 10.0b16, a Process Created and a Process Ended trigger started behaving very strangely.
When said process is started or ended, the triggered function runs with a random 5-30 seconds delay.
Affects one of the triggers as
https://www.displayfusion.com/Discussions/View/100b14-process-created-triggers-stopped-working/?ID=5ee7b18c-fe10-4922-ab0e-8df53f0d8ecf
but not all of them and it is extremely weird because the delay seems to be totally random (but it's always delayed).
I only have 2 sets of Process Created/Ended triggers and the other one seems to be working fine, but I can make some more for testing if that helps.
Window Created triggers seem to be working.

This bug was introduced in 10.0b16, tested and confirmed by rolling back to 10.0b15 where it is not present, then updating to 10.0b16 where it is present again.

Please look into this and let me know if I can help with any additional info or testing.

Thanks!
May 17, 2022 (modified May 17, 2022)  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Could you send me over a screenshot of a trigger this issue is happening with?

Thanks!
May 17, 2022  • #2
Hollo
73 discussion posts
Sure thing!
Attached all my OK/NOK triggers I'm currently using.

In the meantime, I've also found out that the problem is definitely the trigger and not the function (even a simple info popup gets the delay).
• Attachment [protected]: created_NOK.jpg [101,318 bytes]
• Attachment [protected]: created_OK.jpg [97,320 bytes]
• Attachment [protected]: ended_NOK.jpg [102,672 bytes]
• Attachment [protected]: ended_OK.jpg [99,344 bytes]
May 17, 2022  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Thanks for sending those over, I was able to reproduce it on my end so I've added it to our list to look into.

Thanks!
May 18, 2022  • #4
Hollo
73 discussion posts
Great, thanks!
Could you please tell me what the problem with this particular trigger is?
I can't, for the life of me, see any difference between the OK and NOK ones.
May 18, 2022 (modified May 19, 2022)  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Are you referring to the delay between the two apps? It does seem to be different per application, I tested with notepad on my end and there seemed to be a 1 or 2 second delay, but Firefox seemed to have around a 10 second delay. Both used the exact same trigger, so it's something we'll look into.

Thanks!
May 19, 2022  • #6
Hollo
73 discussion posts
I see, I suspected it was application dependent, apparently I just didn't notice the delay in the "OK" case because it was not that long.

Thanks!
May 19, 2022  • #7
Was this helpful?  (-)  (-)