Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Apps disappearing from taskbar

Avatar from Gravatar.com
helmutjd
15 discussion posts
I've noticed that sometimes, if I have connected to my multimonitor PC via RDP earlier in the day and then disconnected, when I physically sit down in front of the PC later in the day, many of my applications will no longer show up on the Windows or DF taskbars.

I'm not sure how useful a report this will be as I can't consistently reproduce it (and honestly, I can't even be sure it's RDP-related, although it always seems to follow an RDP connection) but what I *think* is happening is, when I connect via RDP, Windows moves all of the windows that were on my 2nd, 3rd, and 4th monitors to my main monitor. That allows me to see those windows via RDP, since my laptop only has a single screen. I think the problem, though, is that when those windows were originally moved to my secondary monitors, DF had to hide them from the main Windows taskbar... and when Windows moved them all back to the main monitor during the RDP connection, Windows wasn't smart enough to make their taskbar buttons visible again.

Not sure if my description makes sense -- if not just ask and I'll clarify. :)

Obviously if the root issue could be fixed that would be ideal, but even if there was just a way in DF (maybe with a hotkey) to have it re-enumerate the window list and make sure all the windows that DF *thinks* it's managing are actually visible on a taskbar, that would work too. It just sucks having to rely on alt-tabbing to access 3/4 of your open applications after an RDP session.

BTW, I'm using DF 3.2.0 stable and Windows 7 Professional. I have a couple of dozen windows affected by this right now, so if you need a report from the Troubleshooting tab I can send one, but I'd prefer to send it privately as there is information in some of the window titles that needs to remain confidential.
Jan 26, 2011  • #1
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Sorry for the late reply, but can you give the new version 3.3 a try and let me know if you still have the same issue? Thanks!
Feb 28, 2011  • #2
Avatar from Gravatar.com
brianbasden
7 discussion posts
Subject line is applicable but this is happening without doing anything RDP-related, and just started when I updated to v3.3.

I have a usually-docked ThinkPad T510 with Windows 7 and Nvidia discrete graphics using the laptop as primary display and a Viewsonic 22" LCD as secondary display (note: I'm not using the odd Win7 pinned/grouped toolbar icons, just the standard XP/Vista toolbar).

Before updating to v3.3, when I would undock, any apps on the secondary toolbar would move to the primary toolbar, although in the case of multiple Excel instances (one on each display), even if I click on the Excel filename on the toolbar I'd often have to use alt-tab/win-tab and ctrl-tab (Excel's default hotkey for switching between multiple worksheets) to get it to come up.

After updating to v3.3, when I undock, the apps on the secondary toolbar no longer move to the primary toolbar, and although I can see them (usually as very small windows) by using alt-tab/win-tab, they won't show up on the laptop display, even if I hit ctrl-~, the DF hotkey I set up to switch apps between monitors...
Feb 28, 2011  • #3
Avatar from Gravatar.com
helmutjd
15 discussion posts
Quote:
Sorry for the late reply, but can you give the new version 3.3 a try and let me know if you still have the same issue? Thanks! :)

No worries, and yes, I just had it happen under v3.3.0 today, so this issue definitely still exists.

Also looks like a couple more folks reported this issue http://www.binaryfortress.com/Forum/index.php?topic=2407.0 just today

Quote:
Subject line is applicable but this is happening without doing anything RDP-related, and just started when I updated to v3.3.

Sounds like a different (or at best, tangentially related) issue. The problem I described and the folks in the above thread described happens only after an RDP connection, and has always been a problem -- it's not specific to 3.3.
Mar 4, 2011  • #4
Avatar from Gravatar.com
zAlbee
32 discussion posts
Quote:
I have a usually-docked ThinkPad T510 with Windows 7 and Nvidia discrete graphics using the laptop as primary display and a Viewsonic 22" LCD as secondary display


I have a ThinkPad W500 and I also see this problem a lot after undocking and/or redocking. I have an external monitor connected via DVI via the dock. Undocking detaches the monitor (as well as keyboard, mouse, etc); redocking reattaches the monitor.

It is hard to describe exactly what happens, as the behaviour always seems different. I undock/redock for every meeting at work, and we have 2-3 meetings a week. I generally don't have time to investigate taskbar icons during those meetings, but I can tell you that it has been happening since before 3.3.
Mar 7, 2011  • #5
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
This is a known issue that I am working to solve for the upcoming Beta 3.
Mar 16, 2011  • #6
Avatar from Gravatar.com
Faizal0908
1 discussion post
Oh okay..so known issue. I was about to ask the same question because I'm having the same problem, is there a fix date expected?
Mar 20, 2011  • #7
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
A fix is coming very soon, this is my top issue right now. Look for the fix in Beta 4 or 5 in the next couple of weeks.
Mar 20, 2011  • #8
Jon Tackabury (BFS)'s profile on WallpaperFusion.com
Can you give the new 3.3.1 Beta 5 a try and let me know how it works for you:
http://www.displayfusion.com/Download/Beta/

Thanks! :)
Mar 30, 2011  • #9
Avatar from Gravatar.com
zAlbee
32 discussion posts
It's not yet fixed for me (Beta 6). Still missing taskbar items after undock. Additionally, for some windows (Explorer), I can restore the taskbar item by alt-tabbing to it. For others (Chrome, Outlook 2007), even though I alt-tab to the windows, they don't reappear in the taskbar.

The good thing is all is restored when reconnecting the monitor/dock.

Any debug steps I can do to help?
Apr 8, 2011  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Can you enable debug logging and send the log file to support@displayfusion.com?

To enable debug logging:

  • Open the DisplayFusion settings
  • Click the Troubleshooting tab
  • Check the “Enable debug logging” box
  • Produce the issue
  • Click the “Open Log Location” button
  • Email the “DisplayFusion.log” text file to support@displayfusion.com

Thanks!
Apr 21, 2011  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
In an effort to cleanup the DisplayFusion forum, this topic is being locked and archived because it applies to an older version of DisplayFusion. If you are using the latest version of DisplayFusion and would still like some assistance, please create a new topic and I'll be happy to help you out. There are also beta versions available for testing the latest features and bug fixes:
http://www.displayfusion.com/Download/Beta/

Thanks! :)
Jun 3, 2011  • #12
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply