Title

Message

Confirm

Want to earn a free DisplayFusion Pro license? We're looking for DisplayFusion translators!
<< DiscussionsReply

Double start menu button on second monitor on Remote Desktop

Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
When I make a connection to Remote Desktop then I can see double and deformed start button on second monitor. Client and target is Windows 7 x64 with Aero.
• Attachment: StartButton-second-monitor-via-Remote-Desktop.png [22,094 bytes]
StartButton-second-monitor-via-Remote-Desktop.png
StartButton-second-monitor-via-Remote-Desktop.png
May 24, 2011  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Could you send me the info from the troubleshooting log when the issue is present?

Also, if you disable and re-enable the Start button (right-click the taskbar, go to Multi-Monitor Taskbar > Start Button), does the Start button go back to looking normal?

Thanks!
May 24, 2011  • #2
Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
Logs (troubleshooting and debug) are in attachments.

Re-enable start button doesn't have any effect -start button is still duplicated and deformed.

When I have disabled option "Visual styles" in Remote Desktop Client then start button looks OK.
• Attachment: Logs.rar [10,065 bytes]
May 25, 2011  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, I'm going to do some more testing on this early next week. I haven't been able to reproduce it so far but I will keep looking into it to see if there's anything I can figure out.

Does the Start Menu actually open if you click either of those buttons, or only if you click one of them?
May 27, 2011  • #4
Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
Yes it works. Behavior is like one button - for example when I move mouse cursor on one of them then both buttons have a hover effect.
• Attachment: Hover.png [3,779 bytes]
Hover.png
Hover.png
• Attachment: Normal.png [3,385 bytes]
Normal.png
Normal.png
May 28, 2011  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Would you be able to send a copy of C:\Windows\Explorer.exe from the computer you're connecting to via Remote Desktop? We'd like to analyze it to see if there's something different about the resource files for the Start button. Please email it to support@displayfusion.com. You'll probably need to copy somewhere on your computer and rename it to Explorer.txt, otherwise it will likely get rejected by our mail server.

Thanks!
May 30, 2011  • #6
Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
Hello,

I sended explorer.exe (ZIPped and renamed to TXT) to you.

Kamil Zmeskal
May 30, 2011  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Awesome, thanks! Everything looked OK, so we're going to look into it a bit more to try and determine what to try next. We'll keep you posted!
Jun 1, 2011  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Sorry for the way late response on this but I haven't had any luck reproducing your issue.

Couple of questions:

- Could you try the latest Beta version to see if your issue still exists?
http://www.displayfusion.com/Download/Beta/

- If you Remote Desktop into other machines that are running DisplayFusion, do they also show the double start button?

Thanks!
Jul 12, 2011 (modified Jul 17, 2011)  • #9
Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
Hi Keith,

new beta still don't works. Icon on second monitor is bad. But I have a new information - there is dependency on setings "Color depth" in RDP client. If I select 32bit color depth then icon is OK (32bit.jpg). If I select lower color depth (8,16,24) then icon is bad (16bit.jpg).

Kamil
• Attachment: 16bit.jpg [84,323 bytes]
16bit.jpg
16bit.jpg
• Attachment: 32bit.jpg [76,938 bytes]
32bit.jpg
32bit.jpg
Jul 12, 2011 (modified Jul 12, 2011)  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Nice catch! I didn't even think to try it at 16-bit colour. After changing my connection settings to 16-bit, mine is definitely messed up.

We'll do some debugging now that we can reproduce the issue here, and we'll hopefully have a fix in one of the next few beta versions.

Thanks!
Jul 12, 2011  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
This issue is fixed in 3.4.0 Beta 8 which was just released. Could you give it a try and let me know how it goes?

Thanks!
Jul 14, 2011  • #12
Avatar from Gravatar.com
Kamil Zmeškal
51 discussion posts
Hi Keith,

in 3.4.0 Beta 8 everything color modes (15,16,24,32bit) works OK!

Thank.

Kamil
Jul 15, 2011  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Awesome, thanks for following up!
Jul 15, 2011  • #14
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply