Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

How to make Remote Desktop go fullscreen?

User Image
crawfish
12 discussion posts
I'm using Windows 11 and DF 10 Beta 16, and I like to always view Remote Desktop as fullscreen. However, at least once a day, I find that when I switch to it, it has spontaneously gone to the restored state, which is a regular floating window. I made a DF trigger that maximizes the window when it gets the focus, but it just maximizes it above the host system taskbar. This is different than clicking the window's maximize button, or hovering over its taskbar icon, right-clicking the thumbnail view, and choosing "Maximize". Both those actions make it go fullscreen. Is there any way to do what I want with DF?
16 days ago  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
If that window can be made full screen via key combination, I can make up a script that sends those keys and you can attach it to your trigger. Just let me know what keys need to be sent.

Thanks!
14 days ago  • #2
User Image
crawfish
12 discussion posts
Win+Up Arrow works
14 days ago  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
I've attached a script below that should do this. You can import it via the DisplayFusion Settings > Functions > Scripted Function > Import Scripted Function.

Hope that helps!
• Attachment: Send Keys Win + Up.dfscript [2,129 bytes]
13 days ago  • #4
User Image
crawfish
12 discussion posts
It works, thanks. Weird that Microsoft is distinguishing user input means of maximizing a window from the programmatic method I expect DisplayFusion is using. But that's Microsoft for you...
10 days ago  • #5
User Image
crawfish
12 discussion posts
Unfortunately, it's even weirder than it seemed. Turns out that if there is an open window in the Remote Desktop session, say, a Notepad++ window, it also receives the Win+Up sent by DisplayFusion, so both the Notepad++ window and Remote Desktop container window are maximized (with Remote Desktop going fullscreen as desired). This does not happen after clicking on the taskbar icon, finding the Remote Desktop window in the restored state, and pressing Win+Up myself; with this sequence, only the Remote Desktop window maximizes (fullscreens), and Notepad++ is left alone.
4 days ago (modified 4 days ago)  • #6
Was this helpful?  Login to Vote(-)  Login to Vote(-)