Save up to 50% off any of our desktop apps in our 2020 Black Friday/Cyber Monday sale,
including DisplayFusion, ClipboardFusion, FileSeek, LogFusion, TrayStatus, and VoiceBot!

Title

Message

Confirm

<< DiscussionsReply

Windows 10 Threshold 2 (v1511) update - active window sometimes doesn't draw on top

Avatar from Gravatar.com
Dempf
12 discussion posts
With the latest Windows 10 update, sometimes the active window does not draw on top of other windows. It is as if certain windows get stuck in a weird priority mode, like "always on top" or "always on bottom". If I drag such a window around my screen, then it will go overtop some windows and underneath other windows. I have not been able to figure out a pattern to what causes this, or what windows it affects. This issue only occurs when DisplayFusion is running.
Nov 15, 2015  • #1
Avatar from Gravatar.com
Randy31416
19 discussion posts
I've seen this a few times recently on WIn 7 64-bit as well, but only with DF running as it now always is.. Sometimes similarly the titlebarbuttons for one window get drawn always on top of everything, and when that window (if it is one of these weird ones that sticks to the back) is moved around then the titlebarbuttons move around independently on top of the other windows. In the back of my mind I've been wondering if this has something to do with windows being run elevated (as in run-as-administrator) among windows that are not, since I run a mixture of these, but have been unable to isolate anything defining about this.
Nov 15, 2015  • #2
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Would you guys be able to attach a copy of your troubleshooting info? Here are the steps:
  • Open the Settings > Troubleshooting tab
  • Click the "Copy to Clipboard" button
  • Paste the text into a text file (please don't paste the text directly into your reply, the formatting gets garbled and makes it difficult to parse)
  • Reply with the file attached

Thanks!
Nov 18, 2015  • #3
Avatar from Gravatar.com
Dempf
12 discussion posts
Attaching troubleshooting log.
• Attachment [protected]: Dempf-displayfusionlog.txt [104,526 bytes]
Nov 20, 2015  • #4
Avatar from Gravatar.com
Randy31416
19 discussion posts
Here is my file. This has happened only 3-4 times, and not in the past few days. But it has happened.
• Attachment [protected]: DisplayFusionTroubleShooting.txt [79,383 bytes]
Nov 20, 2015  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks guys! I'll check out the logs and see if I can spot anything fishy.
Nov 24, 2015  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
@Randy: Did you ever have your taskbars configured to be on the left or right side of the monitor? Your troubleshooting info indicates that the taskbars are on the bottom, but everyone else that's reported this issue so far has their taskbar on the right or left side. Just wondering if that's a contributing factor, or a red herring
Nov 26, 2015  • #7
Avatar from Gravatar.com
Randy31416
19 discussion posts
Never had the taskbars set except on the bottom (as far as I know barring a glitch when first setting things up).
Nov 27, 2015  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
If you guys haven't already, can you try updating to 8.0 Beta 1 (https://www.displayfusion.com/Download/Beta)? I can reproduce this fairly reliably in 7.3.2 now, but can't in 8.0 Beta 1. Just wondering if my test results are inconsistent, or if it's actually no longer an issue in the beta.

Thanks!
Dec 1, 2015  • #9
Avatar from Gravatar.com
Dempf
12 discussion posts
I still have this issue on 8.0 beta 1.
Dec 2, 2015  • #10
Avatar from Gravatar.com
Randy31416
19 discussion posts
I've been running Beta 8.1 and have not seen the problem in quite a while (Win 7 64). At first I was running the current release version (7.3.1) but then switched to the Beta, and I cannot remember whether the problem here happened after the switch or before. I think it likely it happed only before the switch for me on Win 7, and until now I'd forgotten about the change in the release of DF I was using.
Dec 2, 2015 (modified Dec 2, 2015)  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, thanks guys! I was finally able to reproduce it in 8.0 Beta 1 as well. We'll keep working on this and will post an update when we're able to make some more progress.
Dec 2, 2015  • #12
Avatar from Gravatar.com
Dempf
12 discussion posts
Thanks a lot! You're the man!

http://www.ihighfive.com
Dec 2, 2015  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Haha, nice site!
Dec 3, 2015  • #14
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, I think I've narrowed down the source of the problem, but I was wondering if you'd be able to test something out for me to make sure I'm not just crazy

Can you try the following?
  • On the Settings > Taskbar tab, set the Window Preview Style to "Previews disabled, show tooltip"
  • In the Settings > Advanced Settings, set the "Taskbar > Thumbnail Preview Tooltips" option to "Taskbar Buttons and Thumbnail Previews don't have tooltips"
  • Set the taskbars back to the left or right side
  • Restart DF
  • Confirm that tooltips and previews are disabled by hovering a taskbar button on the DisplayFusion taskbar, nothing should show up (Windows taskbar will still show a preview, that's fine)
  • See if this issue still occurs

Thanks!
Dec 8, 2015  • #15
Avatar from Gravatar.com
davveh
8 discussion posts
have applied the settings, will test it out for some time. But it seems OK so far. Been using them for like an hour or two.
Dec 9, 2015  • #16
Avatar from Gravatar.com
Randy31416
19 discussion posts
Keith, I haven't seen the problem for quite some time now, so I am not sure that I can help you trouble-shoot this. If the problem comes back for me I'll try these settings, but otherwise things are stable and working on my Win7 system. As it is I have nothing to report on this issue.
Dec 9, 2015  • #17
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok perfect, thanks guys!
Dec 9, 2015  • #18
Avatar from Gravatar.com
davveh
8 discussion posts
hallo again, been working flawlessly since I changed the settings, havent even rebooted since I last replied. Seems to be a workaround! Dont even know the difference from before so I guess the settings doesnt do much
Dec 11, 2015  • #19
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Awesome, glad to hear it! I think you can re-enable the Window Previews (step 1 in post #15). In my testing, I've re-enabled those, but left the tooltips disabled (step 2 in post #15) and everything still seems to be working correctly.

We'll be sure to post an update when we've fixed up the issue with the tooltips

Thanks!
Dec 11, 2015  • #20
Avatar from Gravatar.com
x70x
1 discussion post
I was having this issue as well, but it appears to be fixed with the tooltips turned off.
Dec 11, 2015  • #21
Avatar from Gravatar.com
Dempf
12 discussion posts
Disabling tooltips worked fine for me for a few hours, but somehow I'm encountering the issue again now (with tooltips still disabled).

Edit: restarting DisplayFusion made the issue go away again.
Dec 12, 2015 (modified Dec 12, 2015)  • #22
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, could you try disabling the Window Previews as well then (step 1 in post #15) and let me know how that works out?
Dec 14, 2015  • #23
Avatar from Gravatar.com
Dempf
12 discussion posts
Disabling window previews *and* thumbnail previews seems to prevent the issue so far. Disabling only thumbnail previews was not as effective for me.
Dec 17, 2015  • #24
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, thanks! Could you try a new test for us?
  • Enable the Window Previews and Tool Tips again
  • Update to DisplayFusion 8.0 Beta 2
  • In the Settings > Advanced Settings, enable the to "SetWindowPos" settings (see attached screenshot)
  • Restart DisplayFusion and see if you run into the window focus issue

Note: There are some side effects of having those two Advanced Settings enabled. TitleBar Buttons will be behind the active window, and the taskbar previews/tooltips may not show in front of the active window. This is just a test to see if having no "TOPMOST" calls in DF "fixes" the issue.

Thanks!
• Attachment: SetWindowPos-Settings.png [63,335 bytes]
SetWindowPos-Settings.png
SetWindowPos-Settings.png
Dec 18, 2015  • #25
Avatar from Gravatar.com
Dempf
12 discussion posts
Hi, sorry for the super late response. It seems that having no topmost calls does prevent the issue from occurring.
Jan 10, 2016  • #26
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, that’s what I suspected. This is definitely a Windows 10 bug related to using TOPMOST calls to bring windows to the front of the z-order. We’ll have to find a way to work around it, but in the meantime, either putting the taskbars on the bottom, or using those Advanced Settings are the best workarounds we can offer.

We’ll be sure to send you an update when we’re able to find a better solution.

Thanks!
Jan 13, 2016  • #27
Avatar from Gravatar.com
Dempf
12 discussion posts
Thanks a ton, Keith! The advanced settings will work fine with my setup for the time being.
Jan 13, 2016  • #28
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No problem, sounds good!
Jan 14, 2016  • #29
Avatar from Gravatar.com
Brayden Moore
1 discussion post
Holy shit.

I've been struggling with this for more than a year and finally found the solution.

Thank you, Keith. Thank you so much.
Sep 7, 2016 (modified Sep 7, 2016)  • #30
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, glad we could help!
Sep 9, 2016  • #31
Was this helpful?  (1)  
<< DiscussionsReply